Bug 247902 - i810 video driver broken for 3D graphics, most visible with Google Earth
i810 video driver broken for 3D graphics, most visible with Google Earth
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 17:20 EDT by Gregory Gulik
Modified: 2008-02-15 22:07 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.23*
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 22:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Gulik 2007-07-11 17:20:29 EDT
Description of problem:

The i810 video driver as distributed with Fedora 7 has a flaw where Google Earth
cannot zoom in past a certain level.  Any attempts to view detail with an
elevation below approx. 500 miles results in a bluish gray screen instead of
detailed images of the Earth.

Version-Release number of selected component (if applicable):

Reproducible on kernel-2.6.21-1.3228.fc7 in both 32-bit and 64-bit platforms.

How reproducible:

Always reproducible on Intel based video systems running Fedora 7.

Steps to Reproduce:
1. Install/upgrade system with Intel video to Fedora 7
2. Download & Install latest release of Google Earth
3. View the world then zoom into to an eye level of about 500 miles or below
  
Actual results:

The world view screen turns a bluish gray.

Expected results:

You should be able to see detailed view of Earth.

Additional info:

This is a problem only with Intel based video.  I have experienced this
personally on a Sony Vaio notebook with Intel video, ASUS P5B-VM motherboard
desktop with Intel video and a friends Asus notebook also with Intel video. 
This problem does NOT occur on another notebook I own with NVIDIA video.  I also
did NOT experience this problem with Fedora Core 6 on the same hardware.  This
problem only showed up after installing/upgrading to Fedora 7.  The details of
the hardware that has this problem is as follows:

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Exp
ress Graphics Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics 
Controller (rev 02)

All the systems I have seen this on use the i810 video driver for X11.
Comment 1 Craig Schlenter 2007-07-26 01:50:44 EDT
See the bug I posted here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249517
which references this url:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/90622
which suggests the bug is in mesa ... I haven't confirmed
that though as I haven't tried compiling a newer mesa....
Comment 2 Gregory Gulik 2007-07-26 08:45:39 EDT
Thanks for the info.  I tried the "workaround" to turn off atmosphere and it did
NOT correct the problem for me.

If this problem is in mesa then why doesn't it affect other 3D cards?

Can we ask Red Hat to push out an update to the mesa packages?
Comment 3 Christopher Brown 2007-09-18 11:06:12 EDT
Hello Gregory,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 4 Gregory Gulik 2007-09-19 16:25:18 EDT
The problem is most definitely still there.

I'm running the latest Fedora 7 kernel 2.6.22.5-76.fc7 and I also downloaded the
latest version of Google Earth.

I was still able to reproduce this problem 100% of the time.
Comment 5 Christopher Brown 2007-09-20 04:14:08 EDT
Okay, thanks for the update Gregory. I'm re-assigning this to the relevant
maintainer who may be able to shed some more light on the issue.

Cheers
Chris
Comment 6 Christopher Brown 2008-01-09 11:38:10 EST
Gregory - can I pester you for an update. I'm guessing you still have the issue.

Dave - are you the right person to be looking at this or should I assign it
elsewhere?
Comment 7 Christopher Brown 2008-02-15 21:25:45 EST
Gregory, no update in a while. Could you test with F8 and see if you have the
same issue? It might be a google earth issue to be honest and so we can't
troubleshoot it. That might also be the reason for the lack of response from the
developers.

I'll close this in a few weeks if there's still no response from reporter or
assignee.
Comment 8 Gregory Gulik 2008-02-15 21:41:14 EST
I'm running F8 on that particular system and Google Earth now works just fine. 
As I'm running the same version of Google Earth that I was running on F7 it
definitely tells me there was some issue in F7 that appears to have been
resolved in F8.

One oddity is that Google Earth takes a very long time to start up on this i810
based system but once it starts it works just fine including zooming in.
Comment 9 Christopher Brown 2008-02-15 22:07:31 EST
Great, thanks for the update Gregory. Good to know.

Note You need to log in before you can comment on or make changes to this bug.