Bug 247906 - kernel 2.6.22-8.fc8 - libata gets into a way of hibernation
kernel 2.6.22-8.fc8 - libata gets into a way of hibernation
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 18:05 EDT by Michal Jaegermann
Modified: 2008-04-04 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 12:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a picture of a frozen screen with libata exception messages (144.88 KB, image/jpeg)
2007-07-11 18:05 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-07-11 18:05:44 EDT
Description of problem:

After /usr/sbin/pm-hibernate a number of messages scrolled
from a screen and ended with:
"ata4: failed to recover some devices, retrying in 5 seconds"
but nothing was ever retried and eventually a power switch was
the only way to recover.

Interestingly enough all what was to required to resume was
already written on a disk and a machine came without noticing
that STD was never completed.

A picture of a frozen screen with libata messages is attached.

Version-Release number of selected component (if applicable):
kernel 2.6.22-8.fc8

How reproducible:
This happened only once although I did not try too many times.

I have to run /usr/sbin/pm-hibernate explicitely as all desktop
elements related to suspend/hybernate vanished from rawhide
soon after F7 release and so far they are not coming back.
Comment 1 Michal Jaegermann 2007-07-11 18:05:44 EDT
Created attachment 159009 [details]
a picture of a frozen screen with libata exception messages
Comment 2 Michal Jaegermann 2007-07-13 13:27:47 EDT
It looks like that I know how to make that repeatable.
/usr/sbin/pm-suspend
wake it up and follow with
/usr/sbin/pm-hibernate
appears to cause an error like the reported one every time.

I tried now with 2.6.23-0.15.rc0.git2.fc8 (this is on a package;
it prefers to call itself 2.6.22-0.15.rc0.git2.fc8).
Comment 3 Bug Zapper 2008-04-04 09:22:30 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Michal Jaegermann 2008-04-04 12:53:50 EDT
I cannot reproduce that now with a hardware I have on hands.

Note You need to log in before you can comment on or make changes to this bug.