Bug 247909 - system-config-audit should be in the Administration menu
system-config-audit should be in the Administration menu
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 19:06 EDT by Miloslav Trmač
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 21:10:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2007-07-11 19:06:43 EDT
Version-Release number of selected component (if applicable):
redhat-menus-8.9.10-3.fc7

system-config-audit has a .desktop file with
  Categories=Settings;
The menu entry is in System/Settings, but it should be in System/Administration.

Reading /etc/xdg/menus/system-settings.menu, there are thee ways to do this:
- add a Monitor category - which is incorrect for s-c-audit.
- add a SystemSetup category - which is not in the desktop menu spec 1.0.
- add an explicit <Filename> reference to system-settings.menu.

The most correct option seems to be to add the hard-coded reference.  If that is
so, please add it (file name system-config-audit.desktop).
Comment 1 Ray Strode [halfline] 2007-07-11 21:10:35 EDT
Hi,

Unfortunately our menus weren't completely spec compliant in F7.  This is fixed
in rawhide.  I would recommend adding SystemSetup in F7 (and either ignoring the
desktop-file-utils spew or redirecting it to /dev/null) and use 

Categories=Settings;System;

for rawhide.  Fixing the menus in F7 now would have a lot of potential to break
random apps menu placement unfortunately.  We could do another redhat-menus
release but this isn't actually the first request to get an item added, and
doing a release every time seems like a lot more hassle than just using the
existing category.

Note You need to log in before you can comment on or make changes to this bug.