Bug 247926 - animations grow and don't fit in canvas
animations grow and don't fit in canvas
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcompris (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 22:03 EDT by Alexandre Oliva
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-13 09:53:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 456599 None None None Never

  None (edit)
Description Alexandre Oliva 2007-07-11 22:03:28 EDT
Description of problem:
In the drawing and animation tool, if you draw a square (no fill) taking up the
entire canvas, take a picture then play the animation, you'll see that the
square outgrows the canvas in the animation screen, and the left and upper
borders don't match, rather than fitting perfectly.

Version-Release number of selected component (if applicable):
gcompris-8.2.2-2.fc7
Comment 1 Hans de Goede 2007-07-12 16:53:44 EDT
I cannot reproduce this with 8.3.2 (from rawhide). I can draw a square that is
slightly larger then the canvas bounding line, it seems that the center of the
square line is limited to the canvas bounding line, but since the line is > 1
pixel wide it is slightly of canvas, but it is slightly over canvas everywhere,
not just left and upper as you describe, also it looks exactly the same in the
anim as it does while drawing.

Can you try 8.3.2 from rawhide, notice that you will get a missing icon error
warning, I already have this fixed and will do a new rawhide build with this fix
in tomorrow.
Comment 2 Alexandre Oliva 2007-07-12 21:25:37 EDT
So I rebooted into rawhide (I keep parallel installs) and the problem was still
there.  Took pictures.  Go back to F7.  Started gcompris, and the problem was
"gone".

That's because the gcompris configuration files had been upgraded, and the
choice of 1024x768 over 800x600 had been discarded.  Once I went back to
1024x768, the problem was back.
Comment 3 Hans de Goede 2007-07-13 06:01:20 EDT
I can reproduce this now, I'll try to fix it as time permits.
Comment 4 Hans de Goede 2007-07-13 09:53:15 EDT
gcompris draws everything at 800x600 and then scales it, hence the icons etc,
also become somewhat ugly when running in 1024x768. It seems that the animation
when drawn somehow gets scaled to much / its coordinates get calculated wrong.

Unfortunately fixing this requires deeper knowledge of the inner workings of
gcompris then I have, so I've filed this upstream and will let them handle it.

Note You need to log in before you can comment on or make changes to this bug.