Bug 247944 - conduit can't sync tomboy notes to a folder
conduit can't sync tomboy notes to a folder
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: conduit (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-12 04:03 EDT by Valent Turkovic
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 12:05:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
complete log (8.29 KB, application/octet-stream)
2007-07-12 04:07 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2007-07-12 04:03:58 EDT
Description of problem:


Version-Release number of selected component (if applicable):
tomboy 0.4.1
conduit 0.3.1

How reproducible:
every time

Steps to Reproduce:
1. start conduit
2. ad tomboy as data provider and add folder for where to sync to
3. start sync
  
Actual results:
gives error and doesn't sync

Expected results:
to have my tomboy notes synced to a folder

Additional info:
here is a log of the events:

[  DEBUG] Sync <SyncWorker(Tomboy Notes twoway wrapper (UID:
TomboyNoteTwoWay-valentt@fedora) |--> [<conduit.ModuleWrapper.ModuleWrapper
instance at 0x86d8d2c>], started)> beginning. Slow: False, Twoway: False
[  DEBUG] GUI got sync started
[  DEBUG] Icon got sync started
[  DEBUG] Syncworker state 0
[  DEBUG] Syncworker state 1
[  DEBUG] Source Status = Ready
[WARNING] Tomboy DBus interface not found
[WARNING] RefreshError: Tomboy Notes twoway wrapper (UID:
TomboyNoteTwoWay-valentt@fedora)
[WARNING] Sync Aborted
[  DEBUG] Saving mapping DB to /home/valentt/.conduit/mapping-dev.db
[  DEBUG] GUI got sync completed
[  DEBUG] Icon got sync completed 0 (error: True)
Comment 1 Valent Turkovic 2007-07-12 04:07:18 EDT
Created attachment 159038 [details]
complete log

Here is the complete log from conduit from when I start it, create sync pair
(tomboy-folder) and at the end the error I get when I try to sync them
together.
Comment 2 Bernard Johnson 2007-07-12 04:44:24 EDT
Unfortunately, this was a missed dependency:

$ grep 'TOMBOY_MIN_VERSION =' /usr/lib/python2.4/site-packages/conduit/dataproviders
TomboyModule.py:TOMBOY_MIN_VERSION = "0.5.10"

The latest Tomboy for Fedora is 0.4.1.  The dbus interface is not even named the
same in the older version.

Your best bet is to file a RFE against tomboy for an upgrade, although I
wouldn't hold my breath on that one either.

I'll update the spec in cvs though to reflect that it needs tomboy >= 0.5.10.
Comment 3 Bernard Johnson 2007-07-12 04:45:35 EDT
(In reply to comment #2)
> The latest Tomboy for Fedora is 0.4.1.  The dbus interface is not even named the
> same in the older version.

That should read "The latest Tomboy for Fedora *6* is 0.4.1."
Comment 4 Valent Turkovic 2007-07-12 06:52:58 EDT
I enagled developement repositor for FC6 and installed tomboy 0.7.1 on my FC6
box and now I get conduit to sync ok.

I updated my tomboy from 0.4.1 to tomboy-0.7.1-1.fc8 without any other dependencies.

So if you want to do the same just issue:
yum update tomboy --enablerepo=development

Can you please look at why Conduit doesn't have icon for gmail, you can also see
it in my full log. Do I need to report this icon missing as a separate bug.
Comment 5 Bernard Johnson 2007-07-12 12:05:09 EDT
Yes, please report it as a another bug.  Please also state which desktop theme
you are using and include the log on that report as well.
Comment 6 Valent Turkovic 2007-07-17 02:52:20 EDT
I posted another bug for missing icon.

So you are saying that this can't be fixed - that conduit on fc6 can't sync
tomboy notes?
Comment 7 Bernard Johnson 2007-07-17 04:12:58 EDT
(In reply to comment #6)
> I posted another bug for missing icon.

Thanks you

> So you are saying that this can't be fixed - that conduit on fc6 can't sync
> tomboy notes?

I'm saying that I can't fix it in Conduit.  This feature require a newer tomboy.
 If Tomboy were to be upgraded, it would fix the problem.

This was caused by an oversight on my part as far as the exact version
requirements of Tomboy.
Comment 8 Valent Turkovic 2007-07-18 13:26:36 EDT
Ok, thank you for clarification.
I'm happily running tomboy 0.7.1 via devel repo and I'm syncing with conduit to
my left and to my right :)

Note You need to log in before you can comment on or make changes to this bug.