Bug 247946 - Kernel panic at boot when LVM root shapshot is full
Kernel panic at boot when LVM root shapshot is full
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Milan Broz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-12 04:15 EDT by Egon Kastelijn
Modified: 2013-02-28 23:05 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.22.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 08:34:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Egon Kastelijn 2007-07-12 04:15:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.4) Gecko/20070603 Fedora/2.0.0.4-2.fc7 Firefox/2.0.0.4

Description of problem:
When an lvm snapshot is created of the root filesystem and this snapshot gets full, then the machine hangs with a kernel panic at boot time.



Version-Release number of selected component (if applicable):
lvm-2.02.24-1.fc7  kernel-2.6.21-1.3228.fc7

How reproducible:
Always


Steps to Reproduce:
1. lvcreate -s -n fglrx_test -L 100M /dev/VolGroup00/LogVol00
2. <use the machine until the shapshot is full>
3. reboot


Actual Results:
Kernel panic:
Reading all physical volumes. This may take a while...
device-mapper: table: 253:3: snapshot: Failed to read shapshot metadata
device-mapper: reload ioctl failed: Invalid argument
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

Expected Results:
A normal boot

Additional info:
-
Comment 1 Milan Broz 2007-07-13 08:19:54 EDT
Patch in the way to stable kernel.
For reference here:
http://www.kernel.org/pub/linux/kernel/people/agk/patches/2.6/editing/dm-snapshot-permit-invalid-activation.patch
Comment 2 Milan Broz 2007-10-11 08:34:42 EDT
Fixed since kernel 2.6.22.2 (in f7 updates and rawhide).

Note You need to log in before you can comment on or make changes to this bug.