Bug 247950 - Programs completion
Programs completion
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bash-completion (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-12 04:43 EDT by Jakub 'Livio' Rusinek
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 13:11:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub 'Livio' Rusinek 2007-07-12 04:43:01 EDT
Description of problem:

I think, bash should tell us, what command (package) to run (install).
It will make our life faster and nicer.

How reproducible:

Run from bash program, which is not installed. You'll only see "command not found".
  
Actual results:

You'll only see "command not found", when program is not installed.

Expected results:

Completion on about package/command.
Comment 1 Ville Skyttä 2007-07-12 13:11:40 EDT
Hm, so if a user types "foo" and hits TAB, if there are no things installed that
start with "foo", bash-completion would invoke 'repoquery --file "/usr/bin/foo*"'?

I don't think that's feasible.  First, running repoquery even with all needed
repodata files locally available takes much too long for this purpose, and even
if it were faster, I don't see how it would be useful to "complete" let's say
"foo" TAB to "foofoomatic-0:3.0.2-47.1.fc7.x86_64".  And completing it to "yum
install foomatic-0:3.0.2-47.1.fc7.x86_64" would be dangerous as it would most
likely change the meaning of the "foo" command the user intended when he started
to type it.

Anyway, if you disagree, this is a feature request which would be better
directed at the upstream bash-completion author instead of its Fedora packagers.

Note You need to log in before you can comment on or make changes to this bug.