Bug 247954 - Blocking yum access
Summary: Blocking yum access
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-updatesd (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-12 08:55 UTC by Jakub 'Livio' Rusinek
Modified: 2008-08-02 23:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 19:04:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of yum. (3.61 KB, text/plain)
2008-01-06 13:10 UTC, Michael De La Rue
no flags Details
command history (643 bytes, text/plain)
2008-01-12 20:17 UTC, Roman Danilov
no flags Details

Description Jakub 'Livio' Rusinek 2007-07-12 08:55:20 UTC
Description of problem:

yum-updatesd and pupplet is blocking access to yum instead of informing about
updates. Yes, it shows the info, but what when I don't have time to update and
want install software?

Version-Release number of selected component (if applicable):


How reproducible:

Run Fedora, when updates daemon is enabled and try to install software, when
updates are available.

Actual results:

Blocked access.

Expected results:

Not blocked access.

Comment 1 David Lutterkort 2007-11-01 02:01:23 UTC
Why is this filed against puppet ? Doesn't look like a puppet problem to me ..
please reassign to somebody more appropriate


Comment 2 David Lutterkort 2007-12-14 19:22:47 UTC
Reassigning to Jeremy, since he's the owner of yum-updatesd

Comment 3 Michael De La Rue 2008-01-06 13:10:50 UTC
Created attachment 290909 [details]
Strace of yum.  

I have the same situation.  If I try to install software I get the following
message: (e.g. from "yum install httpd").  My updates don't happen. I suspect
that I may have another repository active 

Existing lock /var/run/yum.pid: another copy is running as pid 16872.
Another app is currently holding the yum lock; waiting for it to exit...

Worse; yum-updatesd doesn't respond to kill -1 or kill -15.  I have to do a
kill -9 and risk (in theory) database corruption.  

This is with: yum-updatesd-3.2.8-2.fc7

Attached is an strace of yum-updatesd sitting there doing not much.

Comment 4 Roman Danilov 2008-01-12 20:17:07 UTC
Created attachment 291475 [details]
command history

Comment 5 Roman Danilov 2008-01-12 20:20:05 UTC
Comment on attachment 291475 [details]
command history

I have the same problem, and no update until kill process which hangs...

Comment 6 Jakub 'Livio' Rusinek 2008-01-12 21:17:02 UTC
Not sure if I should say this, but openSUSE has similliar issue with their
zypper :> .

Comment 7 Jeremy Katz 2008-05-28 19:04:40 UTC
Fedora 8's yum-updatesd should be a lot better in this respect


Note You need to log in before you can comment on or make changes to this bug.