Bug 24801 - pump doesn't seem to get IP from RoadRunner
pump doesn't seem to get IP from RoadRunner
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-23 21:46 EST by Wade Minter
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Minter 2001-01-23 21:46:51 EST
Running "ifdown eth0" then "ifup eth0" causes pump to fail, and dhcpd to
start.

I'm on RoadRunner.  Pump seems to be having problems in general in beta2. 
I'd be glad to run more tests if need be, since this is pretty sketchy
information.
Comment 1 Bill Nottingham 2001-01-23 23:23:45 EST
Can you try the one currently in rawhide?
Comment 2 Wade Minter 2001-01-23 23:47:09 EST
Pump seems to be working through rawhide, but I still have the -d problem
detailed in 24673.

However, it appears that two versions of pump get started upon bootup:

[minter@courthouse minter]$ ps auxwww | grep -i pump
root       275  1.4  0.7  1416  600 ?        S    23:51   0:00 /sbin/pump -d -i eth0
root       291  0.0  0.5  1388  436 ?        S    23:51   0:00 /sbin/pump -d -i eth0
minter     702  0.0  0.7  1556  584 pts/0    S    23:52   0:00 grep -i pump
[minter@courthouse minter]$ 

The second one goes away eventually:

[minter@courthouse minter]$ ps auxwww | grep -i pump
root       275  0.5  0.7  1416  600 ?        S    23:51   0:00 /sbin/pump -d -i eth0
minter     734  0.0  0.7  1556  584 pts/0    S    23:53   0:00 grep -i pump
[minter@courthouse minter]$ 

Comment 3 Wade Minter 2001-01-24 10:20:53 EST
Additional information - I find that I lose my lease and it's not renewed. 
Running "ifdown eth0; ifup eth0" won't get the IP back - pump tries, times out,
and dhcpcd gets the lease.  Rebooting the box is the only way to get pump to get
the lease back.
Comment 4 Elliot Lee 2001-08-08 00:30:44 EDT
dhcpcd replaces pump in rawhide, tada.

Note You need to log in before you can comment on or make changes to this bug.