Bug 248010 - cannot create vm on qemu-based setup
cannot create vm on qemu-based setup
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-07-12 13:56 EDT by darrell pfeifer
Modified: 2008-04-07 13:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-07 13:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
virtmanager log from fresh vm creation session (2.19 KB, text/plain)
2007-07-12 18:23 EDT, darrell pfeifer
no flags Details
virt-manager.log from creating a fresh vm (2.18 KB, text/plain)
2007-07-13 12:18 EDT, Mihai Harpau
no flags Details

  None (edit)
Description darrell pfeifer 2007-07-12 13:56:10 EDT
Description of problem:

On a non-HT machine (Inspiron 9300) vm creation fails. Using a default 4 gig
disk image, the image gets initialized then the error occurs. In the previous
incarnation (version just before this one), there was an error message related
to not being able to initialize the network because the default profile wasn't
found, though this no longer happens.

Version-Release number of selected component (if applicable):

How reproducible:

This was making a qemu based install, taking all the defaults except using a
disk image rather than a partition.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

Unable to complete install '<class 'libvirt.libvirtError'>
virDomainCreateLinux() failed 
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 681, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 649, in
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 666, in
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 521, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed
Comment 1 Daniel Berrange 2007-07-12 14:03:46 EDT
What version of RPMs for  libvirt, qemu, kvm and virt-manager please ? Also can
you grab & attach $HOME/.virt-manager/virt-manager.log or 
/root/.virt-manager/virt-manager.log from immediately after trying to create the VM.
Comment 2 darrell pfeifer 2007-07-12 18:23:01 EDT
Created attachment 159104 [details]
virtmanager log from fresh vm creation session

The mac address doesn't correspond to an valid mac address on the machine
(neither the wired eth0 or the wireless eth1). It should be using the wireless
Comment 3 darrell pfeifer 2007-07-12 18:26:13 EDT
Comment 4 Daniel Berrange 2007-07-12 22:37:51 EDT
The log file doesn't show anything untoward. The MAC address listed is the MAC
address asigned to the guest's virtual NIC - ie eth0 inside the guest. This is
not expected to match the host NIC's MAC address - you guest will be connected
to the host network with NAT, so this is fine.

How much RAM have you got in your host OS in total ?

Could you also see if there is anything under /var/log/libvirt/qemu  ?
Comment 5 darrell pfeifer 2007-07-12 23:01:15 EDT
The host machine has 1 gig of ram. Swap is available but not used.

Tried reducing the size of the virtual machine to 256M but same result.

The /var/log/libvirt/qemu is created but has 0 bytes.

Comment 6 Mihai Harpau 2007-07-13 12:14:33 EDT
I have exactly the same error on F7.
The version of programs used are:
Comment 7 Mihai Harpau 2007-07-13 12:18:44 EDT
Created attachment 159204 [details]
virt-manager.log from creating a fresh vm
Comment 8 Daniel Berrange 2007-07-15 16:32:08 EDT
Can you tell me what kernel version you are using ? Also, are you on Fedora 7,
or rawhide ?
Comment 9 darrell pfeifer 2007-07-15 19:29:14 EDT

The machine is updated from rawhide pretty much every day.

I've tried several different times (I think I did use FC7 at one point) but
haven't been successful yet.
Comment 10 Cole Robinson 2008-03-12 16:42:41 EDT
Hi, is this still an issue on either F8 with the latest packages?
Comment 11 darrell pfeifer 2008-04-07 13:54:33 EDT
The bug report has gotten stale since virt-manager has changed quite a bit. I'll
close this and open another bug report if I see it happening again on a recent

Note You need to log in before you can comment on or make changes to this bug.