Bug 248028 - serial console capabilities are not detected, just forced to vt100-nev
Summary: serial console capabilities are not detected, just forced to vt100-nev
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Joel Andres Granados
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-12 18:51 UTC by Grzegorz Jaskiewicz
Modified: 2008-02-14 21:08 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 21:08:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for inclusion of term=value argument. (3.00 KB, text/x-patch)
2008-02-13 20:06 UTC, Joel Andres Granados
no flags Details

Description Grzegorz Jaskiewicz 2007-07-12 18:51:44 UTC
Description of problem:

 serial console capabilities are not detected, just forced to vt100-nev

 here are ways to query console server about capabilities - "ESC CSI c", 
 in  response - nothing or "\033[?1;2c" means vt100, "\033[?62;1;2c" means 
 vt220 (colors and goodies). please use that in init.c (anaconda) instead of 
 hardcoding it for serial consoles, and (bah!) Xen consoles.



How reproducible:

 use xterm, or anything else - that is proper console termial with anaconda
 over serial console or xen serial. You get black/white output, no F keys 
 working, etc, etc.


Expected results:

 expected to work with proper console terminals.

I don't really know how to patch it, so that you guys won't reject patch.
My best shot would be changing setupTerminal, so before setting 
TERM=vt100-nav - it also sends "ESC CSI c" and checks the response.

Comment 1 Chris Lumens 2007-08-23 20:41:59 UTC
Changing product to Fedora devel since this isn't likely to make it into a RHEL
update release...

Comment 2 Joel Andres Granados 2008-02-13 20:05:54 UTC
Think that adding an argument is the way to go here: term=value.  It will fall
back to vt100-nav (thats what it was doing).  

Comment 3 Joel Andres Granados 2008-02-13 20:06:33 UTC
Created attachment 294828 [details]
patch for inclusion of term=value argument.

Comment 4 Joel Andres Granados 2008-02-14 10:42:03 UTC
Before commiting:  What was the problem with using the utf8 command line
argument?  That activates vt110.

Comment 5 Joel Andres Granados 2008-02-14 21:08:11 UTC
Tested on installations with serial cables and on xen installations and the
vt110, vt220 and vt520 terminal present the same behavior (as far as I can
tell).  If you feel compelled to getting this into rawhide please give a test
case in which vt220 or vt520 has advantages over vt110.
Clossing....


Note You need to log in before you can comment on or make changes to this bug.