This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 248041 - [RFE] Greater Role Granularity required
[RFE] Greater Role Granularity required
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.4
All Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: FutureFeature, Reopened, Triaged
: 248383 (view as bug list)
Depends On: 428182
Blocks: sat-nextgen
  Show dependency treegraph
 
Reported: 2007-07-12 15:49 EDT by Issue Tracker
Modified: 2014-09-18 13:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-23 10:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2007-07-12 15:49:32 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2007-07-12 15:49:35 EDT
I have an issue based around package and configuration file management within Satellite.  

        I would like all application area's to use Satellite to manage their software (Non OS products or specific ones) and configuration files .. and don't want them to have access to the main OS packages etc..   This would give BA great benefits particularly round the Sarbannes Oxley compliance that we have to achieve..   I can't see a way to do it with the current release without making things so complex ie: A satellite server for every application ! - so not a solution. 

I would like to be able to give "application owners" control of their configuration files that are deployed by satellite.   I may also like to give them access so that they can control the uploading of their own RPM's and subsequent deployment to "their" servers.   What I don't want the "application area" to have access to the OS RPM's or configuration files.

Eg: we create a "Config channel" for each application and I would like them to be able to manage the config channel for themselves but nothing else within Satellite.  The current control means that you have to give them org admin rights and this is way to high level.   I hope this is a more indepth explanation.   I believe that other companies have requested this functionality and it has also been escalated by some of your consultants. 


This event sent from IssueTracker by tdunnon  [SEG - Feature Request]
 issue 121856
Comment 5 Máirín Duffy 2007-10-09 10:42:46 EDT
this is not a usability bug. it is a feature request. reassigning to feature queue.
Comment 13 Miroslav Suchý 2011-01-21 07:26:52 EST
*** Bug 248383 has been marked as a duplicate of this bug. ***
Comment 23 Bryan Kearney 2014-05-23 10:10:19 EDT
The RBAC model in Satellite 6.0, and the use of orgs, environments, and content views, should meet the requiremenets which you have stated above. When Satellite 6 comes out, please verify your scenarios. If they are not met please feel free to re-open this bug or open new specific RFE requests against Satellite6 features.

Note You need to log in before you can comment on or make changes to this bug.