Bug 248044 - [RFE][Satellite] Need WebUI mechanism to identify duplicate system profiles to prevent entitlement wastage
[RFE][Satellite] Need WebUI mechanism to identify duplicate system profiles t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
Martin Minar
: FutureFeature, Triaged
: 161565 (view as bug list)
Depends On:
Blocks: sat540-dup-profiles
  Show dependency treegraph
 
Reported: 2007-07-12 15:51 EDT by Issue Tracker
Modified: 2016-07-03 20:54 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 10:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2007-07-12 15:51:59 EDT
Escalated to Bugzilla from IssueTracker
Comment 6 Máirín Duffy 2007-10-09 10:43:53 EDT
this is not a usability bug. it is a feature request. reassigning to feature queue.
Comment 9 Máirín Duffy 2008-04-18 16:26:26 EDT
- I want to understand better why activation keys are causing this problem.

- Suggestion to help alleviate the duplicate system profile situation would be
to have a UI, perhaps under where the system entitlements and osftware
entitlements are managed under Your RHN > Subscription Management. This webui
would be similar in purpose to the Virtualization Entitlements webui that warns
you if you are not making the best usage of your virt entitlements. I'm thinknig:

1) have two tabs on the system entitlements page. the page as it is today will
be the default tab named "Modify System Entitlements". The second tab will be
named "Duplicate Systems". This page will list out by system profile name all
the system profiles with more than one system profile. I'll be attaching a
sketch shortly.
Comment 10 Máirín Duffy 2008-04-18 16:32:48 EDT
Actually on second thought i don't like the idea to address this in comment 9.
Instead, I think a better way to approach this is to have a setting whereby you
can indicate:

[x] Automatically delete systems profiles for systems that have not checked in
within the past [______] [ hours | days | weeks | months | years ].
Comment 15 Jeremy West 2008-11-21 15:31:12 EST
*** Bug 161565 has been marked as a duplicate of this bug. ***
Comment 18 Clifford Perry 2009-08-21 09:54:22 EDT
This RFE has many many proposed solutions/requests. I think the original as per subject:

Provide a WebUI mechanism to identify duplicate system profiles


I would propose we use the System Search, add something like:

adding a selection/option for system search - 
"return a list of systems where the profile name is duplicated with at least one or more other registered systems"

 and then the user gets that list of systems and can throw them to SSM or whatever to delete duplicate profiles 
- for a usability stance.. making it easy to see which is the newest registered (systemid) instance of that would be good to do as well...


Cliff
Comment 19 Máirín Duffy 2009-08-24 10:44:25 EDT
Would it be possible to add a column to search results, 'Registration Date'? Or maybe better, 'Profile Age' ?
Comment 21 Martin Minar 2010-09-24 09:01:48 EDT
Verified in 5.4 version.

New tab
Systems>Systems>Duplicate Systems - where user can search duplicated system by IP address, mac address or host name.
Comment 24 Clifford Perry 2010-10-28 10:47:21 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.