Bug 248053 - (CVE-2007-3741) CVE-2007-3741 Gimp image loader multiple input validation flaws
CVE-2007-3741 Gimp image loader multiple input validation flaws
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
: Security
Depends On: 247566 247567 247568 247569 247570 247571 247572 247573 247574 833902
  Show dependency treegraph
Reported: 2007-07-12 16:17 EDT by Josh Bressers
Modified: 2016-03-04 06:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-12-22 17:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2007-07-12 16:17:59 EDT
The release of Gimp 2.2.16 fixed this item:
- improved input value validation in several file plug-ins (bug #453973)

This bug:

fixes several input validation flaws in the way the Gimp loads various
Comment 1 Nils Philippsen 2007-07-13 05:42:05 EDT
the psd fixes cause a regression with images that contain zero
width/height layers
Comment 2 Nils Philippsen 2007-07-13 05:50:19 EDT
waiting for 2.2.17 which should be ready soon
Comment 3 Nils Philippsen 2007-07-13 16:17:10 EDT
built pkgs for RHEL2.1 - RHEL5 with fixes for (as of yet) known security issues
Comment 5 Vincent Danen 2010-12-22 17:04:41 EST
This was addressed via:

Red Hat Enterprise Linux version 2.1 (RHSA-2007:0513)
Red Hat Enterprise Linux version 3 (RHSA-2007:0513)
Red Hat Enterprise Linux version 4 (RHSA-2007:0513)
Red Hat Enterprise Linux version 5 (RHSA-2007:0513)

Note You need to log in before you can comment on or make changes to this bug.