Bug 248065 - dovecot depends on openldap-devel, but this dependency is not registered
dovecot depends on openldap-devel, but this dependency is not registered
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-12 18:13 EDT by Filip Miletic
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.34-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 13:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Miletic 2007-07-12 18:13:05 EDT
Description of problem:
Libraries in openldap-devel are being used by programs requiring openldap. 
However, openldap does not list openldap as a dependency.  It is thus possible
to remove openldap-devel and end up with a system in which e.g. postfix or
dovecot do not work.

Version-Release number of selected component (if applicable):
openldap-2.3.34-0.fc7

How reproducible:


Steps to Reproduce:
1. Install openldap, openldap-devel, postfix
2. Run ldd on the postfix executable, observe no unresolved libraries
3. Remove openldap-devel
4. Run ldd on the postfix executable and observe that libldap.so and liblber.so
are unresolved
  
Actual results:
Programs that require libldap.so and liblber.so stop working.

Expected results:
The removal of libldap.so and liblber.so should not pass unnoticed if there are
programs depending on them.

Additional info:
Comment 1 Tomas Janousek 2007-07-13 05:00:27 EDT
I am not seeing this.

The dovecot-auth binary in F7 (dovecot-1.0.0-11.fc7) properly depends on
libldap-2.3.so.0 and liblber-2.3.so.0 (which are provided by the openldap package).

The master binary in F7 (postfix-2.4.3-2.fc7) as well.

What versions of dovecot and postfix do you have?
Comment 2 Filip Miletic 2007-07-13 12:58:57 EDT
dovecot-1.0.1-12.fc7
postfix-2.4.3-2.fc7

Can you run the steps to reproduce that I gave, on say postfix?

On my system, 
libldap-2.4.so.0 is a link to libldap.so, which links further to 
libldap_r-2.3.so.0.2.22.

Uninstalling openldap-devel removes the link "libldap.so", thus leaving the
system no way to get to the library.

Comment 3 Tomas Janousek 2007-07-13 13:52:44 EDT
Oh yeah, I can see it now. That's clearly a bug in the openldap package.
Comment 4 Jan Safranek 2007-07-13 15:33:11 EDT
There is no library provided by openldap-devel, removing the package just breaks
"few" symlinks... and nobody restores them. You must manualy run 'ldconfig' as
root and everything will be fine.
 
I'll fix it in next release, so it will do it automatically on uninstall,
Comment 5 Fedora Update System 2007-07-16 12:54:08 EDT
openldap-2.3.34-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Filip Miletic 2007-07-22 07:32:36 EDT
I tried the package from devel, and it seems to be OK.  IMHO ticket can be closed.
Comment 7 Fedora Update System 2007-07-30 13:07:17 EDT
openldap-2.3.34-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.