This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 248105 - NM says that there is no vpnc software, although there is
NM says that there is no vpnc software, although there is
Status: CLOSED DUPLICATE of bug 243535
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-13 05:39 EDT by Matěj Cepl
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 07:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2007-07-13 05:39:32 EDT
Description of problem:
Trying to run vpnc via Network Manager but when trying to add new VPNC
definition I get error message (roughly back translated from Czech): "I cannot
add VPN connection.\n\nThere was no suitable software for VPN found in your
system. Please contact the administrator of your system."

That's nonsense, I have all the software installed (it would be nice if the
error message which exact packages should be installed to satisfy it) and VPNC
runs on my system every day (via ifup vpn_str).

Version-Release number of selected component (if applicable):
sh-3.2# rpm -qa \*vpnc\*
NetworkManager-vpnc-0.6.4-3.fc7
vpnc-consoleuser-0.4.0-2.fc7
vpnc-debuginfo-0.4.0-2.fc7
vpnc-0.4.0-2.fc7
sh-3.2# 

How reproducible:
100%

Steps to Reproduce:
1.click on NM icon and select VPN connections, in submenu select Configure VPN
2.click on icon Add
3.
  
Actual results:
error message happens

Expected results:
dialog window (or wizard or whatever) for setting up VPN should happen

Additional info:
just to be sure you know, I have SELinux in Permisssive mode and there is no
message either in /var/log/audit/audit.log nor /var/log/messages.
Comment 1 Denis Leroy 2007-08-17 02:58:29 EDT
Does this still happen ? Is this on x86_64 (if yes, this is almost certainly a
duplicate of bug 243535).

If you look at the file /etc/NetworkManager/VPN/nm-vpnc-service.name, can you
make sure its fields point to existing files ?
Comment 2 Matěj Cepl 2007-08-17 07:24:08 EDT
Yes, /etc/NetworkManager/VPN/nm-vpnc-service.name is screwed up. Thanks for
pointing me to the problem.

*** This bug has been marked as a duplicate of 243535 ***

Note You need to log in before you can comment on or make changes to this bug.