Bug 248106 - redland.pc contains unneeded linkage requirement
Summary: redland.pc contains unneeded linkage requirement
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: redland   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-13 09:57 UTC by Mamoru TASAKA
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 1.0.5-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 16:57:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mamoru TASAKA 2007-07-13 09:57:49 UTC
Description of problem:
redland.pc contains:
----------------------------------------------------------
Libs: -L${libdir} -lrdf    -ldb-4.5 -lcrypto -L/usr/lib/mysql -lmysqlclient -lz
-lcrypt -lnsl -lm -L/usr/lib -lssl -lcrypto -lsqlite3   -L/usr/lib -lpq
----------------------------------------------------------
Note: "-lmysqlclient" means redland-devel requires mysql-devel
      "-lpq" means redland-devel requires postgresql-devel
      ... etc ....

All these extra linkage requirements is not needed 
as librdf.so is already linked against these libraries 
and must be removed from .pc file.

Version-Release number of selected component (if applicable):
redland-devel-1.0.5-1.fc8

How reproducible:
100%

Comment 1 Kevin Kofler 2007-07-13 17:19:09 UTC
Darn, Murphy must always strike somewhere. Always that portability hack to 
redundantly link libraries, when it's not .la files, it's .pc files, grrr... 
I'll take care of this problem ASAP.

Comment 2 Kevin Kofler 2007-07-14 09:05:39 UTC
Fixed package built for all branches:
- add missing Requires: pkgconfig to the -devel package
- get rid of pkgconfig dependency bloat (#248016)

Pushing this as an F7 update too (F8 and FE6 will automatically get it at the 
next Rawhide resp. Extras push).

Comment 3 Kevin Kofler 2007-07-14 09:07:25 UTC
Darnit, I can't even copy a Bugzilla ID properly! :-( Fixing.

Comment 4 Kevin Kofler 2007-07-14 09:14:48 UTC
Bug number fixed. :-)

Comment 5 Kevin Kofler 2007-07-14 09:31:21 UTC
I just noticed redland-config has the same problem. Fixing there too.

Comment 6 Kevin Kofler 2007-07-14 09:43:11 UTC
Fixed that one too, but ultimately redland-config needs to go away completely 
(replaced with a pkgconfig script) because it's a multilib conflict. But that 
also needs to be fixed in rasqal and raptor.

Comment 7 Fedora Update System 2007-07-16 16:57:25 UTC
redland-1.0.5-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.