Bug 248167 - Functions missing from gnumeric
Functions missing from gnumeric
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-13 12:32 EDT by Ian Dall
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-13 15:18:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace Output (52.10 KB, text/plain)
2007-07-13 12:32 EDT, Ian Dall
no flags Details

  None (edit)
Description Ian Dall 2007-07-13 12:32:55 EDT
Description of problem:
Gnumeric is missing standard functions. For example the ONLY maths functions
available are sum and product

Version-Release number of selected component (if applicable):
1:1.6.3-6.fc7

How reproducible:
Always

Steps to Reproduce:
1.Start gnumeric
2.Select the f(x) icon.
3.Select "Mathematics" as the category of functions
  
Actual results:
Sum and Product are diplayed



Expected results:
Heaps more functions like there used to be with earlier releases. eg where is sqrt?


Additional info:

The plugins seem to all be there in /usr/lib/gnumeric/1.6.3/plugins.

I ran an strace -e trace=file gnumeric and the xml files in the plugin director
are all loaded, but the .so files are never accessed.
Comment 1 Ian Dall 2007-07-13 12:32:55 EDT
Created attachment 159207 [details]
Strace Output
Comment 2 Hans de Goede 2007-07-13 15:18:46 EDT
Hmm,

I've had this bug report before. Please goto tools->plugins and make sure that
you have all the relevant plugins enabled.

Did you install from the livecd? That was involved the last time someone
reported the plugin settings being off by default.

Anyways closing this as works for me. Please reopen if the plugin settings are
not the culprit.
Comment 3 Ian Dall 2007-07-14 01:30:07 EDT
Thanks,
enabling the plugins does the trick. The thing is, I don't recall ever having to
do this before. No it is not livecd. This did happen following an upgrade (not a
fresh install) of Fedora 7.

I did have a little trouble with getting gnome to work properly on my personal
account after the upgrade until I cleaned out some gconf files. Perhaps I messed
up the gnumeric configuration in the process.

A quick check shows that logging in as another user, things are OK by default.

Sorry for wasting everyones time!

Note You need to log in before you can comment on or make changes to this bug.