Bug 248183 - /usr/include/glib-2.0/glib/gtypes.h includes glibconfig.h which doesn't exist
/usr/include/glib-2.0/glib/gtypes.h includes glibconfig.h which doesn't exist
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-13 15:12 EDT by John Ellson
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 16:33:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2007-07-13 15:12:52 EDT
Description of problem:
/usr/include/glib-2.0/glib/gtypes.h includes glibconfig.h which doesn't exist

Version-Release number of selected component (if applicable):
glib2-devel-2.13.6-1.fc8.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Ellson 2007-07-13 15:37:09 EDT
Never mind - I found it in its weird location:
   /usr/lib64/glib-2.0/include/glibconfig.h

The bug must be in the code I'm building.
Comment 2 Hans de Goede 2007-08-21 16:33:31 EDT
Indeed,

[hans@shalem devel]$ pkg-config --cflags glib-2.0
-I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  
[hans@shalem devel]$ 

Maybe your package is not using pkgconfig (like mine which got me here)

Anways, not a bug, closing.

Note You need to log in before you can comment on or make changes to this bug.