Bug 248262 - iso images produced by genisoimage-1.1.16 contains bad joliet data
iso images produced by genisoimage-1.1.16 contains bad joliet data
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-14 13:30 EDT by Mogens Kjaer
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.1.6-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 17:16:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mogens Kjaer 2007-07-14 13:30:45 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Generate .iso file with genisoimage -J
2. Burn CD
3. Read CD on Windows machine
  
Actual results:
CD unreadable

Expected results:
Readable CD

An warning message like:

genisoimage: Unexpected joliet directory length 1700 expected: 1704 ''

is produced by genisoimage as well.

Going back to genisoimage-1.1.12 fixes the problem.

See also:


http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=429244 

Additional info:
Comment 1 Pedro 2007-08-18 04:39:38 EDT
I observe the same problem on my Fedora 7 installation,  but my genisoimage is
not 1.1.16 nor 1.1.12, but rather 1.1.6:

  # rpm -q genisoimage
  genisoimage-1.1.6-1.fc7

Comment 2 Richard Körber 2007-09-02 16:50:34 EDT
It was working fine with genisoimage-1.1.6-1.fc7 on my system for nearly two
months. Now suddenly I get this error:

genisoimage: Unexpected joliet directory length 210 expected: 214 ''

I have reviewed the updates that were installed in the last couple of days, but
did not find any suspect package that may have broken genisoimage. I also tried
and compiled cdrkit-1.1.6-2.fc8.src.rpm, but it didn't help either.

Now I don't have the slightest clue what caused the trouble. Please help! :)
Comment 3 Harald Hoyer 2007-09-20 15:37:57 EDT
Please try
http://koji.fedoraproject.org/koji/buildinfo?buildID=19091
Comment 4 Richard Körber 2007-09-20 17:42:18 EDT
Thanks, Harald. I have tried genisoimage-1.1.6-3.fc7.i386.rpm from Koji.

Good news: The bug seems to been fixed. There is no "Unexpected joliet directory
length" error any more, and the DVD can be read in Windows.

Bad news: Now I get a strange warning instead.

  $ genisoimage -JR iso > burn.iso
  Unknown file type (unallocated) iso/.. - ignoring and continuing.

It seems to do no harm, though.

The mkisofs and mkhybrid symlinks to genisoimage are missing in the koji RPM.
This breaks growisofs, which uses mkisofs. It was working again after I have
added the symlinks manually.
Comment 5 Harald Hoyer 2007-09-21 02:56:37 EDT
ok, fixed the bogus warning.
The symlinks should have been installed by alternatives in the post section.
$ ls -l /usr/bin/mkisofs 
lrwxrwxrwx 1 root root 25 2007-09-21 08:43 /usr/bin/mkisofs ->
/etc/alternatives/mkisofs
$ ls -l /etc/alternatives/mkisofs
lrwxrwxrwx 1 root root 20 2007-09-21 08:43 /etc/alternatives/mkisofs ->
/usr/bin/genisoimage
Comment 6 Harald Hoyer 2007-09-21 04:24:09 EDT
Here we go:
http://koji.fedoraproject.org/koji/taskinfo?taskID=168932
Comment 7 Harald Hoyer 2007-09-21 04:27:15 EDT
Here we go again (wrong link in comment #6):
http://koji.fedoraproject.org/koji/buildinfo?buildID=19195
Comment 8 Richard Körber 2007-09-23 08:47:42 EDT
1.1.6-4 is working now, and the symlinks are also properly set. Thank you!
Comment 9 Fedora Update System 2007-09-25 04:24:25 EDT
cdrkit-1.1.6-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2007-10-03 17:15:58 EDT
cdrkit-1.1.6-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.