Bug 248312 - Missing dependency for qemu package
Missing dependency for qemu package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-15 16:29 EDT by Jonathan Underwood
Modified: 2007-12-01 10:35 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.3.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-01 10:35:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2007-07-15 16:29:49 EDT
Description of problem:
kvm doesn't Require the qemu package, and so a yum install kvm doesn't pull qemu
onto the system. This results in confusion for the end user - see BZ #248305 for
example.

Version-Release number of selected component (if applicable):
kvm-24-1
Comment 1 Jeremy Katz 2007-07-15 20:10:39 EDT
Ummm, there's no requirement at all from kvm on qemu anymore.  In the past, it
was required for keymaps and BIOSen, but kvm has its own copy these days due to
needing a fix in the video BIOS beyond released qemu.

I don't know what virt-manager is doing and without details, I don't really want
to be pulling in all of qemu.
Comment 2 Daniel Berrange 2007-07-15 22:13:29 EDT
It is not a direct requirement of virt-manager per se. Its actually an artifact
of the way libvirt support for KVM is implemented. The KVM code is just one
variant of the more generic QEMU support, and this requires presence of the QEMU
binary. So, at this time, to provision KVM guests requires that QEMU also be
installed. I don't see any big issue with  the KVM RPM depending on the QEMU rpm
since the AFAIK, the upstream intention is still that KVM will ultimately merge
with main QEMU codebase, being just a '--kvm' flag to the main 'qemu' binary. 
Comment 3 Jeremy Katz 2007-07-16 09:36:33 EDT
That's a bug in libvirt then.  Although the long-term may be that kvm gets
merged, it's not the case now.  So libvirt should be checking for the existence
of qemu-kvm to know whether or not kvm is available.  Hacking around it in
packaging is entirely the wrong answer.
Comment 4 Daniel Berrange 2007-12-01 10:35:52 EST
This issue is fixed in libvirt-0.3.3. It is now possible to launch KVM guests
without having QEMU installed.

Note You need to log in before you can comment on or make changes to this bug.