Bug 248317 - luci sets incorrect permissions on /usr/lib64/luci and /var/lib/luci
Summary: luci sets incorrect permissions on /usr/lib64/luci and /var/lib/luci
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Ryan McCabe
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-16 00:10 UTC by Wade Mealing
Modified: 2009-04-16 22:58 UTC (History)
4 users (show)

Fixed In Version: RHSA-2007-0640
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 15:38:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2007:0640 normal SHIPPED_LIVE Moderate: conga security, bug fix, and enhancement update 2007-11-08 14:19:24 UTC

Description Wade Mealing 2007-07-16 00:10:07 UTC
Description of problem:

Permissions set on /var/lib/luci and /usr/lib64/luci are not correct.

Version-Release number of selected component (if applicable):

luci-0.9.2-6.el5

Additional information as it comes in.

Comment 2 Issue Tracker 2007-07-16 15:36:53 UTC
I'm sorry I should have escalated to Bugzilla. This is my previous entry
:

I did a quick test on my system. I changed umask to 0027 and reinstalled
luci.
The rights on /usr/lib/lib were 750 and I was unable to start he service.

I guess we've found where the problem is if you can confirm that umask is
not set to 0022 on your system.

The rights on /var/lib/luci were alright but /usr/lib64/luci was set like
this :

754005    4 drwxr-x---   4 root     root         4096 Jul 12 08:23 .

Do you need further info ?

Cheers,

Sebastien.


This event sent from IssueTracker by saime 
 issue 124326

Comment 5 Ryan McCabe 2007-07-16 21:07:46 UTC
I've committed a patch to CVS that'll fix this when installing with umask more
restrictive than 0022. As a workaround you can set umask to 0022 before installing.

Comment 6 RHEL Product and Program Management 2007-07-16 21:14:10 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 12 errata-xmlrpc 2007-11-07 15:38:15 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2007-0640.html



Note You need to log in before you can comment on or make changes to this bug.