Bug 248318 - Devhelp extension doesn't work due to .desktop filename mismatch
Devhelp extension doesn't work due to .desktop filename mismatch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: deskbar-applet (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-15 20:28 EDT by Kai Thomsen
Modified: 2016-09-19 22:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 18:35:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Python source file patch for deskbar-applet-2.19.3-3.fc7 (446 bytes, patch)
2007-07-15 20:28 EDT, Kai Thomsen
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 382127 None None None Never

  None (edit)
Description Kai Thomsen 2007-07-15 20:28:38 EDT
Description of problem:
When the Devhelp extension ("Developer Documentation") is enabled and you enter 
any search term into the applet's search entry, the menu that opens doesn't 
contain an entry for launching Devhelp.

The reason for this is that the Devhelp extension tries to open a file named 
"devhelp.desktop" on initialization, whereas this file is packaged as "gnome-
devhelp.desktop" in Fedora's devhelp RPM ("gnome" being the vendor prefix). The 
extension fails silently and doesn't provide its service.

Version-Release number of selected component (if applicable):
2.19.3-3.fc7

How reproducible:
always

Steps to Reproduce:
1. Make sure Devhelp/"Developer Documentation" is enabled in the applet 
preferences.
2. Enter any search term into the applet's input field.
  
Actual results:
The menu that opens doesn't provide a Devhelp entry.

Expected results:
There should be a menu entry for launching Devhelp with the given search term.

Additional info:
Comment 1 Kai Thomsen 2007-07-15 20:28:38 EDT
Created attachment 159284 [details]
Python source file patch for deskbar-applet-2.19.3-3.fc7
Comment 2 Alex Lancaster 2007-07-17 20:51:47 EDT
I can also confirm bug, I filed the original upstream bug.
Comment 3 Fedora Update System 2007-07-18 16:52:24 EDT
deskbar-applet-2.19.3-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-07-23 11:43:51 EDT
deskbar-applet-2.19.3-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-08-17 12:15:28 EDT
deskbar-applet-2.19.3-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.