Bug 248342 - snmpwalk does not read TCP scalars
snmpwalk does not read TCP scalars
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp (Show other bugs)
5.0
All Linux
urgent Severity high
: rc
: ---
Assigned To: Jan Safranek
GSSApproved
: ZStream
: 378031 (view as bug list)
Depends On: 248196
Blocks: 246139 296411 372911 385511
  Show dependency treegraph
 
Reported: 2007-07-16 05:52 EDT by Jan Safranek
Modified: 2010-10-22 12:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0376
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:41:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Safranek 2007-07-16 05:52:46 EDT
+++ This bug was initially created as a clone of Bug #248196 +++

$ rpm -q net-snmp
net-snmp-5.1.2-11.EL4.7

and I get:
snmpwalk -v1 -c public localhost  .1.3.6.1.2.1.6

TCP-MIB::tcpRtoAlgorithm.0 = INTEGER: other(1)
TCP-MIB::tcpRtoMin.0 = INTEGER: 200 milliseconds
TCP-MIB::tcpRtoMax.0 = INTEGER: 120000 milliseconds
TCP-MIB::tcpMaxConn.0 = INTEGER: -1
TCP-MIB::tcpActiveOpens.0 = Counter32: 3261918
TCP-MIB::tcpPassiveOpens.0 = Counter32: 621191
TCP-MIB::tcpAttemptFails.0 = Counter32: 2433
TCP-MIB::tcpEstabResets.0 = Counter32: 480959
TCP-MIB::tcpCurrEstab.0 = Gauge32: 25
TCP-MIB::tcpInSegs.0 = Counter32: 112145954
TCP-MIB::tcpOutSegs.0 = Counter32: 114675625
TCP-MIB::tcpRetransSegs.0 = Counter32: 93175

Now I upgrade:

$ rpm -q net-snmp
net-snmp-5.1.2-11.EL4.10

and I only  get

TCP-MIB::tcpInErrs.0 = Counter32: 0
TCP-MIB::tcpOutRsts.0 = Counter32: 2049678

Note: I've removed the tcpConn table stuff.

This is on a 32-bit system, if that matters

-- Additional comment from jsafrane@redhat.com on 2007-07-16 05:29 EST --
It seems to me that net-snmp-5.1.2-11.EL4.10 got some fixes from upstream
breaking the OID comparsions, causing the 'getnext' requests to skip some TCP
scalars. I have patch prepared. In the meantime, you can use snmpget to get the
values you need:

snmpget -v1 -c public localhost  TCP-MIB::tcpRtoAlgorithm.0
TCP-MIB::tcpRtoAlgorithm.0 = INTEGER: other(1)
Comment 1 Jan Safranek 2007-08-13 03:21:47 EDT
we have patch for this bug in RHEL 4.6
Comment 7 Jan Safranek 2007-11-12 11:07:53 EST
*** Bug 378031 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2008-05-21 11:41:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0376.html

Note You need to log in before you can comment on or make changes to this bug.