Bug 248345 - Automatic rebuild
Summary: Automatic rebuild
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Dimitris Glezos
QA Contact: Diego Búrigo Zacarão
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-16 11:09 UTC by Alain Portal
Modified: 2007-07-30 14:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 17:31:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alain Portal 2007-07-16 11:09:06 UTC
Is there an automatic rebuild for localized web page?
I commited some fixes 24H ago and I can't see its.

Comment 1 Dimitris Glezos 2007-07-16 14:41:07 UTC
Alain, can you be more specific on which module you saw this and what times did
you check?

Comment 2 Alain Portal 2007-07-16 14:46:31 UTC
I was talking about translate.fpo, so, when I said "automatic rebuild for 
localized web page", I was talking about the french version of the web site.
I just check now, I can't see changes I made yesterday

Comment 3 Diego Búrigo Zacarão 2007-07-16 14:57:35 UTC
I just have tagged fr.po as LIVE.
Please check it again in a hour.

Comment 4 Alain Portal 2007-07-16 15:56:46 UTC
Now it's ok, I can see my last change.
But you don't answer my question ;-)
Are web pages automaticaly rebuild or its needed a human action?

Comment 5 Alain Portal 2007-07-16 15:59:28 UTC
Oups, I don't see it wasn't Dimitri speaking ;-)


Comment 6 Diego Búrigo Zacarão 2007-07-16 17:31:12 UTC
Nowadays that needs a manual action.
For you tag your PO file as LIVE and it to be available at translation.fp.o in
little time, you need to follow some steps:

msgfmt -c <language>.po (certify that there are no errors in your PO file)
cvs ci -m "Log Message" <language>.po (commit it)
cvs tag -F LIVE <language>.po (tag as LIVE)

I guess Dimitris can have more information about automatic update translation of
our web site.  

Comment 7 Alain Portal 2007-07-18 13:05:23 UTC
I don't understand, should I have to tag as LIVE everything I commit?

Comment 8 Diego Búrigo Zacarão 2007-07-18 13:30:47 UTC
No. You *only* must do tag as LIVE the translate.fp.o PO file. You have to do
that temporarily until our system to be able to do itself.

Comment 9 Alain Portal 2007-07-18 13:56:29 UTC
My question was a little buggy ;-)
Should I have to tag as LIVE the fr.po file after everytime I commited it?

Comment 10 Diego Búrigo Zacarão 2007-07-18 22:45:19 UTC
Ah... Yes.
Everytime you commit fr.po for translate.fp.o *module*, you need to do the steps
said above in comment #6. So, in some minutes the web site will be with the last
version of french translation available for french users.

All modules, except the translate.fp.o module, doesn't need be tagged as LIVE.
I hope I'm more clear to you now. :)

Comment 11 Alain Portal 2007-07-19 07:32:21 UTC
Yes, now, it's clear ;-)
Thanks Diego!

Comment 12 Dimitris Glezos 2007-07-20 22:32:54 UTC
We should really try to put everything that could be useful to more than 1
people  on the wiki, so that we can point there in the next occasion.

Alain, since you got the problem solved, maybe you could please publish these
info on the wiki? I think /wiki/L10N/Tools#Website is the place. Me (and
hopefully Diego too) will jump right in and add any information that might be
missing. :)


Note You need to log in before you can comment on or make changes to this bug.