Bug 248355 - Kernel warning in fs/inotify.c, line 172, func set_dentry_child_flags()
Kernel warning in fs/inotify.c, line 172, func set_dentry_child_flags()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-16 08:32 EDT by Christian Mandery
Modified: 2009-03-05 04:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-13 20:41:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 8938 None None None Never

  None (edit)
Description Christian Mandery 2007-07-16 08:32:49 EDT
Description of problem:
Warnings in the kernel log (dmesg):
BUG: warning at fs/inotify.c:172/set_dentry_child_flags() (Not tainted)
 [<c0497a37>] set_dentry_child_flags+0x67/0x13d
 [<c0497c27>] remove_watch_no_event+0x2f/0x3b
 [<c0497d15>] inotify_remove_watch_locked+0x12/0x3e
 [<c0600c17>] mutex_lock+0x1a/0x29
 [<c0497fdd>] inotify_rm_wd+0x6d/0x8a
 [<c04983b1>] sys_inotify_rm_watch+0x38/0x4f
 [<c0404f70>] syscall_call+0x7/0xb

Appears randomly, about every second/third day.

Version-Release number of selected component (if applicable):
2.6.21-1.3228.fc7

How reproducible:
Wait some hours until it comes up randomly.
  
Actual results:
Kernel warning but (as far as I can see) no processes killed, data lost or other
"ugly" behavior.

Expected results:
No warning.
Comment 1 Helge Deller 2007-08-23 09:17:53 EDT
still happens with latest kernel-2.6.22.1-41.fc7:
WARNING: at fs/inotify.c:172 set_dentry_child_flags() (Not tainted)
 [<c049b72f>] set_dentry_child_flags+0x67/0x13d
 [<c049b91f>] remove_watch_no_event+0x2f/0x3b
 [<c049ba0d>] inotify_remove_watch_locked+0x12/0x3e
 [<c060a81b>] mutex_lock+0x1a/0x29
 [<c049bcd5>] inotify_rm_wd+0x6d/0x8a
 [<c049c0a9>] sys_inotify_rm_watch+0x38/0x4f
 [<c0404f8e>] syscall_call+0x7/0xb
 [<c0600000>] xfrm_add_sa+0x3e7/0x491
 =======================

Although this bug/warning isn't critical, it's still strange...
Comment 2 Dave Jones 2007-08-29 15:52:34 EDT
Being chased upstream too..  http://bugzilla.kernel.org/show_bug.cgi?id=8938
no-one is sure why this is happening.
Comment 3 Chuck Ebbert 2007-09-04 19:13:48 EDT
Possible fix is here:

http://bugzilla.kernel.org/attachment.cgi?id=12196&action=view
Comment 4 Christian Mandery 2007-09-06 07:55:53 EDT
I think, this is fixed upstream now, changing resolution to UPSTREAM.
Comment 5 Chuck Ebbert 2007-09-06 15:53:03 EDT
Not fixed upstream yet.
Comment 6 Helge Deller 2007-11-13 06:52:24 EST
still happens on latest FC7 Kernel: kernel-2.6.23.1-21.fc7
WARNING: at fs/inotify.c:172 set_dentry_child_flags() (Not tainted)
 [<c04a3887>] set_dentry_child_flags+0x67/0x13d
 [<c04a3a77>] remove_watch_no_event+0x2f/0x3b
 [<c04a3b65>] inotify_remove_watch_locked+0x12/0x3e
 [<c061bb2b>] mutex_lock+0x1a/0x29
 [<c04a3e2d>] inotify_rm_wd+0x6d/0x8a
 [<c04a4201>] sys_inotify_rm_watch+0x38/0x4f
 [<c040518a>] syscall_call+0x7/0xb
 =======================
Comment 7 Christopher Brown 2008-01-09 12:01:38 EST
Helge,

You should add yourself to the kernel bug upstream:

http://bugzilla.kernel.org/show_bug.cgi?id=8938

as it would appear the maintainer has had issues getting someone to test a fix.
Comment 8 Helge Deller 2008-01-09 12:37:55 EST
Thanks Christopher. I'll do.
Comment 9 Christopher Brown 2008-01-13 18:36:41 EST
I'm closing this as a dupe of bug #287411 as that has more information and as
such is policy for duplicate bugs. Thanks for adding yourself to the upstream
bug and for filing this one originally - it is greatly appreciated.

*** This bug has been marked as a duplicate of 287411 ***
Comment 10 Ian Kent 2008-01-13 20:34:57 EST
(In reply to comment #9)
> I'm closing this as a dupe of bug #287411 as that has more information and as
> such is policy for duplicate bugs. Thanks for adding yourself to the upstream
> bug and for filing this one originally - it is greatly appreciated.
> 
> *** This bug has been marked as a duplicate of 287411 ***

This is almost certainly net the same problem as that
in 248411. It's a coincidence that the reporter saw
that in his logs as well. Please also see 427581.

Comment 11 Ian Kent 2008-01-13 20:41:31 EST

*** This bug has been marked as a duplicate of 287411 ***
Comment 12 Helge Deller 2008-02-20 13:00:01 EST
Just saw the problem again with kernel 2.6.23.15-80.fc7.
Since upstream think it's fixed with 2.6.24, I'll close this bug.
Nevertheless, it's NOT A DUPLICATE of #287411 !!!!
Comment 13 Dennixx 2009-03-05 04:59:58 EST
I have this same problem on a system running RHEL5 server x86_64, all patches applied:
----
BUG: warning at fs/inotify.c:192/set_dentry_child_flags() (Not tainted)

Call Trace:
 [<ffffffff800f180f>] set_dentry_child_flags+0x6e/0x14d
 [<ffffffff800f1926>] remove_watch_no_event+0x38/0x47
 [<ffffffff800f194d>] inotify_remove_watch_locked+0x18/0x3b
 [<ffffffff800f1a88>] inotify_rm_wd+0x8d/0xb6
 [<ffffffff800f1ffe>] sys_inotify_rm_watch+0x46/0x63
 [<ffffffff8005d116>] system_call+0x7e/0x83
----

Will there be a kernel-fix for RHEL for this problem anytime soon?
Or should I just open a new bug?

Note You need to log in before you can comment on or make changes to this bug.