This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 248401 - [RFE] The new title page dialog is not generic enough
[RFE] The new title page dialog is not generic enough
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-16 13:32 EDT by Nicolas Mailhot
Modified: 2008-12-15 13:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 12:08:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
maybe something like this (38.60 KB, image/png)
2008-11-13 07:16 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 79618 None None None Never

  None (edit)
Description Nicolas Mailhot 2007-07-16 13:32:42 EDT
Description of problem:

All the info is available in the upstream bug
Comment 1 Caolan McNamara 2007-07-16 14:00:36 EDT
Yeah, but I don't want it to be a generic dialog, but a very targeted dialog
that addresses the key problem of "how do I make a title page", it has always
been possible to make runs with custom page styles and some trickery.
Comment 2 Nicolas Mailhot 2007-07-16 14:40:00 EDT
The trickery is user-hostile, and you're >< that close to a generic dialog right
now. Just don't assume your special pages are title pages and at the beginning
of the document
Comment 3 Caolan McNamara 2008-04-18 08:40:13 EDT
Got a quick idea as to what you'd like the UI to look like ?
Comment 4 Jon Stanley 2008-04-23 16:30:23 EDT
Adding FutureFeature keyword to RFE's.
Comment 5 Nicolas Mailhot 2008-11-11 06:11:07 EST
(In reply to comment #3)
> Got a quick idea as to what you'd like the UI to look like ?

Not very different from what you did, except with a way to select where the page run starts (for example to create annex pages at the end of the document)
Comment 6 Caolan McNamara 2008-11-13 07:16:48 EST
Created attachment 323442 [details]
maybe something like this
Comment 7 Caolan McNamara 2008-11-13 08:21:50 EST
checked in support for placing title pages at arbitrary postions into F-11
Comment 8 Caolan McNamara 2008-12-11 08:16:45 EST
How about that in rawhide now, does that suit you ?
Comment 9 Caolan McNamara 2008-12-15 12:07:48 EST
Assuming its good, upstream issue updated with our patch.

Ability to select what page the title page stuff happens at available in 3.0.1-13.2.fc11. Defaults to start of document, and alternative select specific page default value is current page of the cursor
Comment 10 Nicolas Mailhot 2008-12-15 13:35:07 EST
Sorry, was away from my rawhide system for a few days.

What's in rawhide looks good UI-wise, except for some reason the page style drop down does not show all the available page styles (no idea if it's rawhide brokeness or not)

Also it's probably better to name it "special pages" rather than "title pages" since it does not work with only title pages anymore

Note You need to log in before you can comment on or make changes to this bug.