Bug 248412 - Closing laptop lid only suspends every second try
Closing laptop lid only suspends every second try
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-16 14:02 EDT by Matthew Saltzman
Modified: 2013-03-05 22:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-01 06:26:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2007-07-16 14:02:50 EDT
Description of problem:
On my Thinkpad T41, attempting to suspend by closing the lid only works on
alternate tries.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.18.3-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Set preferences to suspend when lid is closed (on battery and on A/C).
2. Close lid.
3. Open lid.
4. Close lid.
5. Open lid.
6. Close lid.
  
Actual results:
Laptop suspends on every second lid close.

Expected results:
Laptop suspends on every lid close.


Additional info:
Comment 1 Zack Cerza 2007-07-19 14:44:34 EDT
I'm seeing this on my X41. Resetting severity since this has become fairly
serious for me... if I close my lid and walk away for a few hours, half the time
I come back I almost burn myself picking up my laptop, because I keep forgetting
about this damn bug. It's also a regression.
Comment 2 Matthias Clasen 2007-07-24 20:22:10 EDT
CCing Richard. I believe he has this fixed in svn.
Comment 3 Richard Hughes 2007-07-25 05:43:33 EDT
No, this is a kernel bug. I've sent a patch to LKML and acpi-devel a few times.
I'll cc you both.
Comment 4 Richard Hughes 2008-04-30 05:31:13 EDT
Now fixed in F9?
Comment 5 Matthew Saltzman 2008-04-30 07:50:45 EDT
Seems to be working in F8, in fact.  Will re-open if it pops up again in F9.
Comment 6 Richard Hughes 2008-05-01 06:26:43 EDT
Okay, thanks.

Note You need to log in before you can comment on or make changes to this bug.