Bug 248436 - show e2label in disk druid
Summary: show e2label in disk druid
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Sivák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-16 20:00 UTC by Roland McGrath
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 15:50:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Show labels in graphical partitioning UI (2.18 KB, patch)
2007-08-16 16:12 UTC, Martin Sivák
no flags Details | Diff
FS Label in GUI (2.21 KB, patch)
2007-08-21 07:56 UTC, Martin Sivák
no flags Details | Diff

Description Roland McGrath 2007-07-16 20:00:56 UTC
When using the installer partitioning interface, it would be nice if for
existing partitions and LVs with filesystems, it showed their e2label text along
with the fs type in the list.

Comment 1 Chris Lumens 2007-08-08 20:15:06 UTC
Which dialog and list are you referring to?  Is this in the text mode interface
or the graphical interface?

Comment 2 Roland McGrath 2007-08-08 20:23:54 UTC
I was referring to the top-level all-partitions list/menu in the graphical
interface (the first thing you get to for "custom partitioning").  I'm not sure
I've ever seen the text version of that.  Really, it would be nice for any place
that mentions "/dev/sda23 ext3" to say "/dev/sda23 ext3 LABEL=/foobar".

The top-level menu is what I really noticed the lack in.  On my test machines, I
make oodles of /boot-sized partitions and the rest of the disk in LVM PVs. 
Whenever I'm doing a test install, I have to remember which of the many little
same-sized partitions I was using for which install's /boot.  e2label is ideal
for this.  (I'm not really looking to get fancy specifying anything by label or
anything.  I just want to minimize the keystrokes when I do it all by hand and
now have to go rooting around to check what's on each partition since I can't
remember through a reboot which ones I just assigned to what. ;-)

Comment 3 Martin Sivák 2007-08-16 16:12:49 UTC
Created attachment 161667 [details]
Show labels in graphical partitioning UI

This patch adds the label column for graphical instalation. I'm not sure about
text mode install because the UI would become a little crowded with stuff. The
label is accessable through the edit command anyway.

Comment 4 Martin Sivák 2007-08-21 07:56:12 UTC
Created attachment 161949 [details]
FS Label in GUI

Fixed one small typo..

Comment 6 Martin Sivák 2007-08-24 15:50:15 UTC
Fixed in rawhide. Will show up in the next build.


Note You need to log in before you can comment on or make changes to this bug.