Bug 248462 - race between loading xenblk.ko and scanning for LVM partitions etc.
race between loading xenblk.ko and scanning for LVM partitions etc.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
: Patch
Depends On: 247265
Blocks: 248466
  Show dependency treegraph
 
Reported: 2007-07-16 17:08 EDT by Eduardo Habkost
Modified: 2009-12-14 15:41 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.20-2925.13.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 18:52:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Eduardo Habkost 2007-07-16 17:10:16 EDT
Clone of bug #247265, for Fedora 7.

+++ This bug was initially created as a clone of Bug #247265 +++

Description of problem:
When the xen block frontend driver is built as a module the module load is 
only
synchronous up to the point where the frontend and the backend become 
connected
rather than when the disk is added.

This means that there can be a race on boot between loading the module and
loading the dm-* modules and doing the scan for LVM physical volumes (all in 
the
initrd). In the failure case the disk is not present until after the scan for
physical volumes is complete.

Version-Release number of selected component (if applicable): 2.6.18-8.1.6.EL
Also applies to RHEL4u5 2.6.9-55.0.2.EL

Upstream fix is:
http://xenbits.xensource.com/linux-2.6.18-xen.hg?rev/11483a00c017
http://xenbits.xensource.com/kernels/rhel4x.hg?rev/156e3eaca552

How reproducible:
Not precisely determined. Seems to be related to high load in domain 0 or in
multiple other domains implying delays in scheduling the backend driver. 

Actual results:
  Loading xenblk.ko module
  Registering block device major 202
  xvda:Loading dm-mod.ko module
  <6>device-mapper: ioctl: 4.11.0-ioctl (2006-09-14) initialised:
dm-devel@redhat.com
  Loading dm-mirror.ko module
  Loading dm-zero.ko module
  Loading dm-snapshot.ko module
  Making device-mapper control node
  Scanning logical volumes
  Reading all physical volumes. This may take a while...
  xvda1 xvda2
  No volume groups found
  Activating logical volumes
  Volume group "VolGroup00" not found
  Creating root device.
  Mounting root filesystem.
  mount: could not find filesystem '/dev/root'
  Setting up other filesystems.
  Setting up new root fs
  setuproot: moving /dev failed: No such file or directory
  no fstab.sys, mounting internal defaults
  setuproot: error mounting /proc: No such file or directory
  setuproot: error mounting /sys: No such file or directory
  Switching to new root and running init.
  unmounting old /dev
  unmounting old /proc
  unmounting old /sys
  switchroot: mount failed: No such file or directory
  Kernel panic - not syncing: Attempted to kill init!

Expected results:
  Registering block device major 202
  xvda: xvda1 xvda2
  Loading dm-mod.ko module
  device-mapper: ioctl: 4.11.0-ioctl (2006-09-14) initialised: 
dm-devel@redhat.com
  Loading dm-mirror.ko module
  Loading dm-zero.ko module
  Loading dm-snapshot.ko module
  Making device-mapper control node
  Scanning logical volumes
  Reading all physical volumes. This may take a while...
  Found volume group "VolGroup00" using metadata type lvm2
  Activating logical volumes
  2 logical volume(s) in volume group "VolGroup00" now active

Comment 2 Fedora Update System 2007-07-17 12:44:27 EDT
kernel-xen-2.6-2.6.20-2925.13.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Red Hat Bugzilla 2007-07-24 21:42:52 EDT
change QA contact
Comment 4 Eduardo Habkost 2007-07-31 10:15:23 EDT
Marking as MODIFIED, as fix is on CVS and on updates-testing.
Comment 5 Fedora Update System 2007-07-31 18:52:43 EDT
kernel-xen-2.6-2.6.20-2925.13.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.