This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 24847 - rpm - RFE - read list of packages from a file when installing
rpm - RFE - read list of packages from a file when installing
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 09:00 EST by benedict
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 09:00:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description benedict 2001-01-24 09:00:11 EST
I have 355 packages installed on my system.  If I want to reinstall all of
them, or install them all from
scratch on a new host, I cannot write the full list of fully qualified file
names on the rpm command
line, as this will break my shell command line length limit.

The pipeline

  cat package-file | xargs rpm -U

is not a solution, as it will do several, independent calls to rpm, some of
which mayh fail due to failing dependencies.

rpm ought to be able to read all package file names, and indeed also such
flags as --ignoredeps and
--oldpackage from an input file.

[I have asked for this since the days of rpm-2.x - so now it's in bugzilla
;-) ]
Comment 1 Jeff Johnson 2001-06-16 02:08:41 EDT
rpm-4.0.3 has package manifests, basically glob expressions
that can include remote globs (with URL) and will chain to
other manifest files.

Note You need to log in before you can comment on or make changes to this bug.