Bug 24848 - rpm - RFE - produce list of packages written when building
rpm - RFE - produce list of packages written when building
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 09:07 EST by benedict
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:40:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description benedict 2001-01-24 09:07:33 EST
when rpm builds packages from a spec-file, there is no easy way to know,
what package files
it will actually write, except to capture the output and look for lines
beginning with

Wrote: xxxx-y.z-d.rpm

It would be very handy to have this output by itself in a separate file, 
i.e. a TOC file which lists the paths of all packages produced by the
build.

You can use such a file as a makefile target, i.e. like this:

package.TOC :  package.spec
	rpm -b $(^) --toc=$(@)

[I have asked for this since the days of rpm-2.x - so now it's in bugzilla
;-) ]
Comment 1 Nalin Dahyabhai 2001-01-24 20:26:29 EST
Use "rpm -q --specfile" against the .spec file.
Comment 2 benedict 2001-01-25 06:20:24 EST
"rpm -q --specfile" against the .spec file is not what I'm after.  I don't need
the base file names of the
packages which may or may not be produced when building from a specfile. 

I need the fully qualified names of the packages which were actually written
when the build was performed.

If the build fails (e.g. because a file in the %files list cannot be found),
then the list should be empty.
If a %files is conditional on a specific os, the package name should only occur
in the TOC file if the
package was actually written.

All I ask is a file which collects the output written by this line of code:

build/pack.c:552:     rpmMessage(RPMMESS_NORMAL, _("Wrote: %s\n"), fileName);

on a separate file rather than mixed in with all the other build output.
Comment 3 Nalin Dahyabhai 2001-01-25 15:19:01 EST
Ah, I see.  That *is* different.
Comment 4 Bill Nottingham 2005-09-29 17:40:54 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.

Note You need to log in before you can comment on or make changes to this bug.