Bug 248539 - kernel ignores ENE Technology CB-712/4 SD/MMC card reader
kernel ignores ENE Technology CB-712/4 SD/MMC card reader
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://bugs.launchpad.net/ubuntu/+so...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-17 08:07 EDT by Richard Schwarting
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.21.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 15:17:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
adds entries so that the kernel recognises ENE cb712/4 with PCI id 0x0551 (1.34 KB, patch)
2007-07-17 08:07 EDT, Richard Schwarting
no flags Details | Diff

  None (edit)
Description Richard Schwarting 2007-07-17 08:07:11 EDT
Description of problem:

The SD card reader in my laptop (Acer 5102 WLMi) is manufactured by ENE
Technology.  The kernel shipped by Fedora (and probably the kernel.org kernel)
do not recognise it, though they appear to support it.  The following Launchpad
bug for Ubuntu describes it a bit more:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/62995
There is a patch there which, when adapted and applied to Fedora 7,
succcessfully (!) enables my card reader.  I am reading data from it *right
now*.  All it does is add a new entry in sdhci.c and a new pci id in pci_ids.h.  
I am attaching the patch below, along with my lspci output regarding the cardbus.

note: I do not take credit for the original patch found at the URL, but only for
its meek adaptation to my Fedora 7 system.  Credit I believe goes to Jonáš
Svatoš for figuring it out originally (unless he also only adapted it).



Version-Release number of selected component (if applicable):

kernel 2.6.21-1.3228.fc7

How reproducible:

Always.

Steps to Reproduce:
1. with the above card reader (pci id 0x0551, not 0x0550 which is already
supported), insert an SD memory card
  
Actual results:
* the card is not recognised by the system, because the card reader is not.

Expected results:
* the card is recognised by the system

Additional info:

Perhaps this is not enabled in the kernel.org kernel for a reason, but Googling
around, I cannot find one.  It works rather well with the attached patch for me.  


06:04.0 CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10)
        Subsystem: Acer Incorporated [ALI] Unknown device 009f
        Flags: bus master, medium devsel, latency 168, IRQ 20
        Memory at c0211000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=06, secondary=07, subordinate=07, sec-latency=176
        Memory window 0: 50000000-53fff000 (prefetchable)
        Memory window 1: 54000000-57fff000
        I/O window 0: 0000a400-0000a4ff
        I/O window 1: 0000a800-0000a8ff
        16-bit legacy interface ports at 0001

06:04.1 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader
Controller (rev 01)
        Subsystem: Acer Incorporated [ALI] Unknown device 009f
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at c0210400 (32-bit, non-prefetchable) [size=128]
        Capabilities: [80] Power Management version 2

06:04.2 Generic system peripheral [0805]: ENE Technology Inc ENE PCI Secure
Digital Card Reader Controller (rev 01) (prog-if 01)
        Subsystem: Acer Incorporated [ALI] Unknown device 009f
        Flags: bus master, medium devsel, latency 64, IRQ 23
        Memory at c0210800 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2

06:04.3 FLASH memory: ENE Technology Inc FLASH memory: ENE Technology Inc: (rev 01)
        Subsystem: Acer Incorporated [ALI] Unknown device 009f
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at c0210c00 (32-bit, non-prefetchable) [size=128]
        Capabilities: [80] Power Management version 2

06:04.4 FLASH memory: ENE Technology Inc SD/MMC Card Reader Controller (rev 01)
        Subsystem: Acer Incorporated [ALI] Unknown device 009f
        Flags: medium devsel, IRQ 23
        Memory at c0210100 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2
Comment 1 Richard Schwarting 2007-07-17 08:07:11 EDT
Created attachment 159416 [details]
adds entries so that the kernel recognises ENE cb712/4 with PCI id 0x0551
Comment 2 Jarod Wilson 2007-07-17 10:30:04 EDT
Patch is already in upstream development kernels and thus our latest rawhide
kernels. Chuck or Dave's call if they want to pick this up for 2.6.22 for FC6
and F7 as well.

Note You need to log in before you can comment on or make changes to this bug.