Bug 248599 - Handling of multiple "same" NFS mounts
Handling of multiple "same" NFS mounts
Status: CLOSED DUPLICATE of bug 209964
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-17 13:48 EDT by Kevin Graham
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 13:16:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Graham 2007-07-17 13:48:18 EDT
As covered in Redhat bug 222138, multiple instances of a NFS mount only use the
options of the first mount. kernel.org bug, from the previously cited issue
covers this very unambiguously:

     http://bugzilla.kernel.org/show_bug.cgi?id=7612

...however this behavior should likely be revisited. From our own experiences
tripping across this and the time this went undiagnosed in issue 222138, clearly
this is far from the "principle of least surprise".

Opening this against RHEL5, since with autofs5's "-hosts" map, the problem could
become decidedly more painful since mounts become administratively
nondeterministic. While I question anyone using a -hosts map anywhere but a
casual desktop environment, there's enough other cases where this could (for
example) leave a daemon chroot'ed into a ro NFS mount actually ending up with a
rw mount.

At the very least, nfs (or further up the VFS stack) should detect this
condition and use the inherited mount options (rather than those provide) to
update the mount tab. Ideally, it should always defer to the "least
conservative" options, though there's enough ambiguous cases ('ro' trumps 'ro',
'nosuid' trumps 'suid' are obvious enough, things like attribute caching are
questionable) that this is likely impractical. While this would likely lead to
plenty of finger pointing at autofs still, at least the mtab would accurately
reflect reality.
Comment 1 Jeff Layton 2007-07-18 13:16:31 EDT

*** This bug has been marked as a duplicate of 209964 ***

Note You need to log in before you can comment on or make changes to this bug.