Bug 24860 - X server (voodoo 3) dies
Summary: X server (voodoo 3) dies
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-24 16:32 UTC by Philip Balister
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 12:08:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xfree log (21.79 KB, text/plain)
2001-01-31 03:55 UTC, Philip Balister
no flags Details

Description Philip Balister 2001-01-24 16:32:02 UTC
If I leave the X server running and as the active virtual console, it will
lock after some random period of time. Like hours. The screensaver is
active when this happens. If I leave a text vc active, I get some error
that I forgot to write down on the console I started X from. If X was the
active console the machine is dead.

Server is whatever I got from RH7, which I got from the Dummies book.

This is pissing me off. The old server I used on RH6 ( I got the XF3.xxxx
server from 3dfx) would freeze during use occasionaly, I was hoping XF4
would behave better.

Philip

Comment 1 Mike A. Harris 2001-01-26 09:55:33 UTC
Is this an AGP or PCI card?  How much RAM, of what type?
Can you do a file attach above of the entire output of your
X server's error log?  Please include any details that might
help track this down.

Have you tried the latest Rawhide RPM's at all?

Also, could you do a query on all voodoo bugs in bugzilla and see if your
symptoms match anyone else's problems with these cards?

Comment 2 Mike A. Harris 2001-01-26 10:10:01 UTC
Try disabling the screen saver and let me know what happens overnight.

Comment 3 Philip Balister 2001-01-31 03:53:28 UTC
OK, no rawhide RPMS, AGP card, haven't seen anything similar searching for
voodoo bugs.
In the good news department, disabling the screensaver leads to : 
9:58pm  up 4 days, 11:29,  3 users,  load average: 1.12, 1.15, 1.09
Since I haven't rebooted, I haven't recalled the specifics of the voodoo3. It is
a pretty basic one though.

Comment 4 Philip Balister 2001-01-31 03:55:29 UTC
Created attachment 8540 [details]
xfree log

Comment 5 Mike A. Harris 2001-04-02 16:28:01 UTC
Your log doesn't show any crash occuring.  Can you attach a log from
after a crash/hang?  Check /var/log/messages as well, it could be a
kernel hang with DRI.  Attach both logs please.

Also, make sure if you use 3D that you are using 16bit depth.  8/24/32
does not work I do not believe.

Comment 6 Mike A. Harris 2001-05-04 12:08:41 UTC
Yep, Voodoo 3 does 3D at 16bpp (which you're using) and Voodoo5 at 16/32bpp.

Can you attach your config file?

Comment 7 Mike A. Harris 2001-06-15 03:15:49 UTC
Unable to reproduce, closing bug due to lack of required
requested information in reasonable time frame.


Note You need to log in before you can comment on or make changes to this bug.