Bug 248600 - Two minor bugs, one in xconfig.py, one in authentication.py
Two minor bugs, one in xconfig.py, one in authentication.py
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-17 13:49 EDT by Robert Frank
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 16:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Frank 2007-07-17 13:49:46 EDT
Description of problem:
I Found a typo when going through source, and found another issue (not really a
bug) with quotes inside of authentication.

Version-Release number of selected component (if applicable):
whatever is in the current F7 repo

1. In /usr/share/system-config-kickstart/xconfig.py, 223,33:
  self.ks.xorg.wideoRam = ""
should probably be
  self.ks.xorg.videoRam = ""

2. If you enter one single or double quote inside of the authentication page
(maybe others), and save the file, then open the file... the quotes are note
escaped so it will not open, and will give you an error about not closing the
quote... As I said before, not really a problem, just something that might cause
problems if they want to put arbitrary data in... like a single quote...
Comment 1 Chris Lumens 2007-07-30 16:36:11 EDT
Fixed #1.  I'm going to close this bug out because of that.  For #2, I'm going
to do a more involved fix in pykickstart that should help with validating all
sorts of input values.

Note You need to log in before you can comment on or make changes to this bug.