Bug 248653 - kdebase: unable to remote login with kdm (LTSP setup)
Summary: kdebase: unable to remote login with kdm (LTSP setup)
Status: CLOSED DUPLICATE of bug 243560
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-17 22:18 UTC by Nadav Kavalerchik
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 22:57:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nadav Kavalerchik 2007-07-17 22:18:47 UTC
Description of problem:
after upgrading from fc6 to fc7, I'm unable to login from a remote terminal
using kdm.

initially i thought it was related to bug report 247455 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=247455
but maybe it's not so. since I've updated the kdelibs package
(that was suggested in that report) which solved that issue.

starting new session locally works when using:
KDE menu --> Switch User --> start new session.

i can't login with "Xnest :7 -query 127.0.0.1" from within root session.

btw. all this was possible before the upgrade to fc7

i'm running "kdm -debug 7" so i can send any helpful log
if you think it's necessary 

Version-Release number of selected component (if applicable):
kde 3.5.7-9 (updated from fc7 testing)

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Nadav Kavalerchik 2007-07-19 13:01:26 UTC
i've installed a fresh fc7 and updated it with latest Testing packages.
and i still can't login remotely

here is wat i get:
"Unknown session exit code 0 (sig 11) from manager process"

Comment 2 Rex Dieter 2007-07-19 14:34:36 UTC
WORKSFORME,
$ rpm -q kdelibs kdebase
kdelibs-3.5.7-9.fc7.i386
kdebase-3.5.7-5.fc7.i386

Have you set in /etc/kde/kdm/kdmrc:
[XDMCP]
Enable=True
and
/etc/X11/xdm/Xaccess appropriately? (I simply added 'localhost')


Comment 3 Nadav Kavalerchik 2007-07-19 15:10:03 UTC
rpm -q kdelibs kdebase
kdelibs-3.5.7-9.fc7
kdebase-3.5.7-0.1.fc7

i've set 
[XDMCP]
Enable=True
and
/etc/X11/xdm/Xaccess to *

still, just after i press enter (in the password field) the KDM login blinks for
a second and it is back again. (doesn't seems to crash!)

i do get this message (in /var/log/messages)
kdm: "Unknown session exit code 0 (sig 11) from manager process"

on the same hardware a fc6 install works fine (when i plug-in in a different HD)

i am not sure if this is related but, i have eth0 down, eth1 down and wlan0 up
maybe it has some thing to do with the network devices ?

Comment 4 Rex Dieter 2007-07-19 15:18:20 UTC
Sure enough, didn't actually try logging in via Xnest.

I had *assumed* all was ok once I saw the login screen.   my bad.

Comment 5 Rex Dieter 2007-07-24 22:57:51 UTC

*** This bug has been marked as a duplicate of 243560 ***


Note You need to log in before you can comment on or make changes to this bug.