Bug 248667 - [ja] python backtrace for timezone '(' format substitution
Summary: [ja] python backtrace for timezone '(' format substitution
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-date   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-07-18 02:09 UTC by Jens Petersen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 07:54:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-date-1.9.1-ja.po-missing-s.patch (692 bytes, patch)
2007-07-18 02:12 UTC, Jens Petersen
no flags Details | Diff
system-config-date-1.9.1-ja.po-missing-s.patch (692 bytes, application/octet-stream)
2007-07-18 02:25 UTC, Jens Petersen
no flags Details
system-config-date-1.9.1-ja.po-missing-s.patch.gz (285 bytes, application/x-gzip)
2007-07-18 02:52 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2007-07-18 02:09:54 UTC
Description of problem:
system-config-date is giving a python backtrace from the timezone
code when run in ja_JP.UTF-8.

Version-Release number of selected component (if applicable):
system-config-date-1.9.1-1.fc8

How reproducible:
every time

Steps to Reproduce:
1. Japanese anaconda install 
2. LANG=ja_JP.UTF-8 system-config-date
  
Actual results:
1. anaconda backtrace:
Traceback (most recent call first):
  File "/usr/share/system-config-date/timezone_map_gui.py", line 275, in
currentCityLabel_set
    labelText = _('Selected city: %(city)s (%(comments)s)') % {'city':
self.cityname_format (self.currentEntry.tz), 'comments':
_(self.currentEntry.comments)}
  File "/usr/share/system-config-date/timezone_map_gui.py", line 582, in setCurrent
    self.currentCityLabel_set ()
  File "/usr/share/system-config-date/timezone_map_gui.py", line 333, in __init__
    self.setCurrent (zonetab.findEntryByTZ (default))
  File "/usr/lib/anaconda/iw/timezone_gui.py", line 77, in timezone_widget_create
    viewportWidth=viewportWidth)
  File "/usr/lib/anaconda/iw/timezone_gui.py", line 63, in custom_widget_handler
    return handler(str1, str2, int1, int2)
ValueError: unsupported format character '(' (0x28) at index 28

2. similar backtrace

Expected results:
no errors

Additional info:
Only seems to happen for Japanese - so looks like a translation issue.
(tested ko, zh and hi too)

Comment 1 Jens Petersen 2007-07-18 02:12:06 UTC
Created attachment 159489 [details]
system-config-date-1.9.1-ja.po-missing-s.patch

This patch to ja.po seems to fix the problem.

Comment 2 Jens Petersen 2007-07-18 02:25:36 UTC
Created attachment 159490 [details]
system-config-date-1.9.1-ja.po-missing-s.patch

replaced with uncorrupted version of patch

Comment 3 Jens Petersen 2007-07-18 02:52:52 UTC
Created attachment 159491 [details]
system-config-date-1.9.1-ja.po-missing-s.patch.gz

take 3

Comment 4 Jens Petersen 2007-07-23 00:48:31 UTC
Any chance of fixing this in time for Test1?

Comment 5 Nils Philippsen 2007-07-23 07:54:34 UTC
fixed in system-config-date-1.9.2 which is building right now


Note You need to log in before you can comment on or make changes to this bug.