Bug 248672 - rt2500pci no longer works in 2.6.21-1.3255.fc7
rt2500pci no longer works in 2.6.21-1.3255.fc7
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 00:04 EDT by Jason Quartarone
Modified: 2007-12-10 15:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 15:33:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from kernel-2.6.21-1.3228.fc7.x86_64 (16.40 KB, text/plain)
2007-07-18 00:04 EDT, Jason Quartarone
no flags Details
dmesg from kernel-2.6.22.1-27.fc7.x86_64 (16.41 KB, text/plain)
2007-07-18 11:46 EDT, Jason Quartarone
no flags Details
dmesg from kernel-2.6.22.1-20.fc7.x86_64 (16.55 KB, text/plain)
2007-07-18 12:49 EDT, Jason Quartarone
no flags Details
dmesg where network works (2.6.21-1.3228.fc7.x86_64) (18.55 KB, text/plain)
2007-07-23 12:06 EDT, Bjarke Skjernaa
no flags Details
dmesg where network broken (2.6.22.1-27.fc7.x86_64) (17.85 KB, text/plain)
2007-07-23 12:08 EDT, Bjarke Skjernaa
no flags Details
dmesg from kernel-2.6.22.9-91.fc7.x86_64 (16.75 KB, text/plain)
2007-10-15 23:56 EDT, Jason Quartarone
no flags Details

  None (edit)
Description Jason Quartarone 2007-07-18 00:04:16 EDT
Description of problem:
rt2500pci no longer works in 2.6.21-1.3255.fc7

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3255.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Have working F7/kernel-2.6.21-1.3228.fc7 rt2500pci configuration.
2. Upgrade to kernel-2.6.21-1.3255.fc7
3. Reboot to new kernel.
4. Attempt to detect networks.

Actual results:
No networks detected.

Expected results:
Networks detected.
Comment 1 Jason Quartarone 2007-07-18 00:04:16 EDT
Created attachment 159496 [details]
dmesg from kernel-2.6.21-1.3228.fc7.x86_64
Comment 2 Jarod Wilson 2007-07-18 09:37:02 EDT
How 'bout with kernel-2.6.22.1-20.fc7.x86_64? I believe it contains some updated
wireless bits over 3228.
Comment 3 John W. Linville 2007-07-18 09:48:01 EDT
I'd rather you try this one, if you don't mind:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=11320
Comment 4 Jason Quartarone 2007-07-18 11:43:25 EDT
kernel-2.6.22.1-27.fc7 didn't fix it.  It also seems to also have broken the
r8169 driver and gave me a new error message for my IDE controller.
Comment 5 Jason Quartarone 2007-07-18 11:46:27 EDT
Created attachment 159530 [details]
dmesg from kernel-2.6.22.1-27.fc7.x86_64
Comment 6 Jason Quartarone 2007-07-18 12:33:43 EDT
kernel-2.6.22.1-20.fc7 does not detect networks either.
Comment 7 Jason Quartarone 2007-07-18 12:49:57 EDT
Created attachment 159539 [details]
dmesg from kernel-2.6.22.1-20.fc7.x86_64
Comment 8 John W. Linville 2007-07-18 13:00:29 EDT
Looks like the driver is getting loaded.  Can you attach the output of 'iwlist 
wlan0 scan'?

Have you tried disabling NetworkManager and configuring the network manually?
Comment 9 Jason Quartarone 2007-07-18 13:59:13 EDT
I tested both 2.6.22.1-20.fc7 and 2.6.22.1-22.fc7 both with NetworkManager
enabled and with it disabled.  I got the following results from all four tests:

wlan0    No scan results

Under 2.6.21-1.3228.fc7 I get "Scan completed" and a list of cells.
Comment 10 Jason Quartarone 2007-07-18 14:53:29 EDT
By 2.6.22.1-22.fc7 I mean 2.6.22.1-27.fc7.
Comment 11 Bjarke Skjernaa 2007-07-23 12:02:14 EDT
I have the same problem with a rt2500usb. Works fine in 2.6.21-1.3228.fc7, but
does not work in 2.6.22.1-27.fc7>

2.6.21: iwlist wlan0 scan:

wlan0     Scan completed :
          Cell 01 - Address: 00:14:BF:72:E2:C9
                    ESSID:"Skjernaa"
                    ....

2.6.22: iwlist wlan0 scan:

wlan0     No scan results

I upload dmesg from the two kernels (note the first added attachment from above
(from 2007-07-18 00:04 EST) is incorrectly named - it is from a
2.6.21-1.3255.fc7.x86_64, where the problem already was present)
Comment 12 Bjarke Skjernaa 2007-07-23 12:06:21 EDT
Created attachment 159791 [details]
dmesg where network works (2.6.21-1.3228.fc7.x86_64)
Comment 13 Bjarke Skjernaa 2007-07-23 12:08:14 EDT
Created attachment 159792 [details]
dmesg where network broken (2.6.22.1-27.fc7.x86_64)
Comment 14 John W. Linville 2007-08-02 15:21:16 EDT
Lots of rt2x00 fixes lately...have you tried 2.6.22.1-41.fc7?
Comment 15 Lars Hansson 2007-08-15 03:01:45 EDT
Still does not work woth 2.6.22.1-41.fc7. My card is a Surecom EP-9001-g (USB).
Comment 16 Jason Quartarone 2007-10-15 23:55:50 EDT
2.6.22.9-91.fc7:

iwlist wlan0 scan
wlan0     No scan results
Comment 17 Jason Quartarone 2007-10-15 23:56:45 EDT
Created attachment 228171 [details]
dmesg from kernel-2.6.22.9-91.fc7.x86_64
Comment 18 Jason Quartarone 2007-10-15 23:57:46 EDT
Comment on attachment 228171 [details]
dmesg from kernel-2.6.22.9-91.fc7.x86_64

2.6.22.9-91.fc7:

iwlist wlan0 scan
wlan0	  No scan results
Comment 19 John W. Linville 2007-10-16 08:22:53 EDT
Have you tried using rt73usb instead of rt2500usb?  There is some overlap 
between the supported devices.
Comment 20 Jason Quartarone 2007-10-16 11:41:48 EDT
I replaced rt2500pci with rt73usb in modprobe.conf and it still loads rt2500pci.

Removing rt2500pci causes a kernel panic.
Comment 21 John W. Linville 2007-10-16 12:46:19 EDT
Add this line to /etc/modprobe.d/blacklist:

blacklist rt2500pci

Then reboot.  Does that make a difference?
Comment 22 Jason Quartarone 2007-10-16 13:21:54 EDT
wmaster0 and wlan0 no longer appear and I get no such device from
system-config-network when I try to probe the MAC address.
Comment 23 John W. Linville 2007-10-22 10:02:46 EDT
Would you mind testing these F8-based kernels?

   http://koji.fedoraproject.org/koji/taskinfo?taskID=203296

Do they improve the situation for you?
Comment 24 Jason Quartarone 2007-10-25 11:58:07 EDT
I get an error message from RPM:

error: unpacking of archive failed on file
/lib/modules/2.6.23.1-28.wl.1.fc8/kernel/fs/fat/fat.ko;4720bcf3: cpio: read
Comment 25 John W. Linville 2007-10-25 12:52:53 EDT
Must be a bad download...try again?
Comment 26 Jason Quartarone 2007-10-26 03:42:00 EDT
w00t -- the network at work was mangling downloads.  Redownloaded at home no
problem.

2.6.23.1-28.wl.1.fc8.x86_64 works

2.6.23.1-35.fc8.x86_64 doesn't
Comment 27 Jason Quartarone 2007-10-26 03:53:45 EDT
I do note that with 2.6.23.1-28.wl.1.fc8.x86_64, I connected at 11 Mbps.
Comment 28 Jason Quartarone 2007-10-26 14:11:27 EDT
iwlist shows speeds of 1, 2, 5.5, 11, 6, 9, 12, 18, 24, 36, 48, and 54 Mbps, but
is opening up at low speeds (1 and 11 Mbps so far) under
2.6.23.1-28.wl.1.fc8.x86_64.
Comment 29 John W. Linville 2007-10-26 14:39:28 EDT
That is working as intended.  It starts slow, then works its way faster if it 
can.  Conditions such as RF propogation and noise can affect the maximum 
available speeds.

Thanks for the report.  I'm not sure if these fixes will make it in before F-8 
ships, but they should at least be an early update.

You might want to try these kernels if you want some of the more recent 
non-wireless updates:

   http://koji.fedoraproject.org/koji/taskinfo?taskID=215849
Comment 30 John W. Linville 2007-11-09 14:26:50 EST
Please try these kernels:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=23734

Are they working satisfactorily for you?
Comment 31 John W. Linville 2007-12-10 15:33:37 EST
Closed due to lack of response.  Please reopen if/when the requested 
information becomes available...thanks!

Note You need to log in before you can comment on or make changes to this bug.