Bug 248688 - Request to add "start", "stop" or similiar parameter.
Request to add "start", "stop" or similiar parameter.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: chkconfig (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 05:10 EDT by Jan ONDREJ
Modified: 2014-03-16 23:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 14:52:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2007-07-18 05:10:49 EDT
Description of problem:
Is it possible to add "start" and "stop" parameters to chkconfig command?
It's requested function can be to set autostarting of this service and also
start it currently. Something like:

if [ "$2" = "start" ]; then
  /sbin/chkconfig $1 on
  /sbin/service $1 start
elif [ "$2" = "stop" ]; then
  /sbin/service $1 stop
  /sbin/chkconfig $1 off
else
  /sbin/chkconfig "$@"
fi


Additional info:
It is only a feature request. If it is not right to add feature requests here,
please tell me where.
May be it is possible to add "on" and "off" parameters to the service command,
but it may be more complicated, because a programmer can define it's own
rc-script paramters.

Thank you.
Comment 1 Bill Nottingham 2007-07-18 14:52:56 EDT
I really think it's better to keep the two concepts separate; enabling versus
starting/stopping.

Note You need to log in before you can comment on or make changes to this bug.