Bug 248704 - Quitting celestia kills xorg
Summary: Quitting celestia kills xorg
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: celestia (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-18 12:04 UTC by Need Real Name
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 14:58:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2007-07-18 12:04:33 UTC
When I have celestia running in a window, closing the window kills X, I have to
wait for it to restart, then log in again.

Comment 1 Need Real Name 2007-07-18 13:35:56 UTC
Actually this seems to happen with a lot of graphics intensive programs, perhaps
the nvidia binary drive is to blame.

Backtrace:0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80c2d21]
1: [0x74e420]2:
/usr/lib/xorg/modules/extensions//libGLcore.so(xmesa_check_and_update_buffer_
size+0x32) [0x1018cf2]
3: /usr/lib/xorg/modules/extensions//libGLcore.so(XMesaResizeBuffers+0x29)
[0x101b489]
4: /usr/lib/xorg/modules/extensions//libGLcore.so [0x101b810]5:
/usr/lib/xorg/modules/extensions//libglx.so [0xd993ba]
6: /usr/bin/Xorg(compPositionWindow+0x59) [0x8105599]7:
/usr/bin/Xorg(ReparentWindow+0x1ac) [0x8077b6c]
8: /usr/bin/Xorg(ProcReparentWindow+0xd5) [0x8089425]9: /usr/bin/Xorg [0x81523c1]
10: /usr/bin/Xorg(Dispatch+0x1aa) [0x80899fa]11: /usr/bin/Xorg(main+0x495)
[0x8071735]
12: /lib/libc.so.6(__libc_start_main+0xe0) [0x5a9f70]
13: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e9) [0x8070a21]
Fatal server error:Caught signal 11.  Server aborting

Comment 2 Steven Pritchard 2007-07-18 14:58:11 UTC
If you are running the nvidia proprietary driver, you need to report this to 
nvidia.  Unfortunately, there's nothing I can do.

If you can reproduce the problem with another card/driver, please reopen this 
ticket.


Note You need to log in before you can comment on or make changes to this bug.