Bug 248717 - kdelibs: build fails against cups-1.3
Summary: kdelibs: build fails against cups-1.3
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-18 13:13 UTC by Rex Dieter
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 3.5.7-20.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 16:03:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdelibs-cups13.patch (1.07 KB, patch)
2007-07-18 14:09 UTC, Tim Waugh
no flags Details | Diff
kdelibs-cups13.patch (1.95 KB, patch)
2007-07-18 14:35 UTC, Tim Waugh
no flags Details | Diff
kdelibs-cups13.patch (2.71 KB, patch)
2007-07-19 14:59 UTC, Tim Waugh
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 148021 None None None Never

Description Rex Dieter 2007-07-18 13:13:40 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=69341

Likely kdelibs' use of decrecated api, but thought you might see some
simple/obvious fix, in particular, code that fails to compile now in
kdelibs-3.5.7/kdeprint/cups/cupsdconf2/cups-util.c, near line 111:

/*
 * See if we should retry the current digest password...
 */
if (strncmp(cups_server->fields[HTTP_FIELD_WWW_AUTHENTICATE], "Basic", 5) == 0
|| digest_tries > 1 || !pwdstring[0])

Comment 1 Tim Waugh 2007-07-18 14:09:26 UTC
Created attachment 159522 [details]
kdelibs-cups13.patch

Try this.  I'm building a kdelibs package locally to test it myself.

Comment 2 Tim Waugh 2007-07-18 14:35:27 UTC
Created attachment 159525 [details]
kdelibs-cups13.patch

There were some fixes missing from the patch.  Try this one instead -- it
builds for me.

Comment 3 Rex Dieter 2007-07-18 18:03:23 UTC
Thanks a bunch Tim.  

Reassigning -> kdelibs
(clearly not a cups bug)

Comment 4 Rex Dieter 2007-07-19 11:55:54 UTC
%changelog
* Wed Jul 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 6:3.5.7-11
- build fails against cups-1.3 (#248717)

I'll keep this open until I can get this upstreamed.

Comment 5 Rex Dieter 2007-07-19 14:07:30 UTC
Compilation gets further... but...

/bin/sh ../../libtool --silent --tag=CC   --mode=link gcc  -DNDEBUG -O2  -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -L/usr/lib/qt-3.3/lib  -Wl,--as-needed
-Wl,--enable-new-dtags   -o make_driver_db_cups make_driver_db_cups.o
../libdriverparse.a ../../kdecore/libkdefakes.la -ldl -lz
ipprequest.cpp: In member function 'bool IppRequest::doFileRequest(const
QString&, const QString&)':
ipprequest.cpp:313: error: invalid use of undefined type 'struct _http_s'
/usr/include/cups/http.h:325: error: forward declaration of 'struct _http_s'
ipprequest.cpp:323: error: invalid use of undefined type 'struct _http_s'
/usr/include/cups/http.h:325: error: forward declaration of 'struct _http_s'
../../kdeprint/management/kmprinterpage.h: At global scope:
../../kdeprint/management/kmprinterpage.h:37: warning: 'class KMPrinterPage' has
virtual functions but non-virtual destructor
../../kdeui/keditlistbox.h:60: warning: 'class KEditListBox::CustomEditor' has
virtual functions but non-virtual destructor
kmcupsmanager.cpp:1017: warning: 'void extractMaticData(QString&, const
QString&)' defined but not used
make[1]: *** [kdeprint_cups_la.all_cpp.lo] Error 1
make[1]: Target `all-am' not remade because of errors.
make[1]: Leaving directory `/builddir/build/BUILD/kdelibs-3.5.7/kdeprint/cups'


Comment 6 Tim Waugh 2007-07-19 14:59:15 UTC
Created attachment 159588 [details]
kdelibs-cups13.patch

It's mucking about with the internals, and it can't do that in CUPS 1.3.  Try
this.

Comment 7 Rex Dieter 2007-07-25 14:09:31 UTC
This last one looks like a winner, thanks.

Looks like upstream is going to be reworking a lot of their cups support soon,
at address (stuff like) this.

Comment 8 Fedora Update System 2007-08-20 16:03:41 UTC
kdelibs-3.5.7-20.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.