Bug 24873 - xfs syslogs to local0 facility
Summary: xfs syslogs to local0 facility
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-24 18:31 UTC by Patrick J. LoPresti
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-15 04:31:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick J. LoPresti 2001-01-24 18:31:12 UTC
This is with the XFree86-xfs-3.3.6-20 package.

When configured to use syslog (as is the default with Red Hat 6.2), the X
Font Server (xfs) sends syslog messages to the "local0" facility.  This is
annoying for us, because we use the localN facilities for local purposes. 
No vendor-supplied tool should log to any localN facility by default.

The "daemon" facility would be more appropriate.  Even better would be
allowing the user to configure the facility at run-time...

Comment 1 Mike A. Harris 2001-03-23 10:27:23 UTC
I like the idea of changing this as you suggest, but it is only realistic
to do so if the XFree86 team thinks it is a good idea as well.  I have asked
the XFree86 team, and am awaiting their reply.  I will decide what to do then.

Comment 2 Mike A. Harris 2001-04-02 14:01:43 UTC
At some point I will investigate changing it to log at the daemon level.

Comment 3 Mike A. Harris 2002-02-01 09:14:03 UTC
I've made this enhancement in XFree86 4.2.0-5.1 in rawhide.  I'll
submit this change upstream to XFree86.org as well.


Note You need to log in before you can comment on or make changes to this bug.