This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 248737 - sata disks are hang for 40 sec
sata disks are hang for 40 sec
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: David Milburn
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 10:20 EDT by Levente Farkas
Modified: 2010-05-07 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 12:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2007-07-18 10:20:14 EDT
Description of problem:
we regulary once a day got such messages in the log file. during this period
(about 40 sec) the whole system hangs and it seems nothing is working on the
server. we already try replace the sate cables update the firmware but nothing
helps. there are 6 sata disk in the server and the strange thing that different
disk fail (so it's not the problem with the disk itself, we already run test on
disk too). the same system runs without problem with rhel 4, this only happened
after upgrading to rhel 5.
anybody has any tip?
-------------------------------------------------
Jul 17 13:31:58 piros kernel: ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0
action 0x2 frozen
Jul 17 13:31:58 piros kernel: ata4.00: tag 0 cmd 0xea Emask 0x4 stat 0x40 err
0x0 (timeout)
Jul 17 13:31:59 piros kernel: ata4: soft resetting port
Jul 17 13:32:01 piros kernel: ata4: softreset failed (1st FIS failed)
Jul 17 13:32:01 piros kernel: ata4: softreset failed, retrying in 5 secs
Jul 17 13:32:06 piros kernel: ata4: hard resetting port
Jul 17 13:32:14 piros kernel: ata4: port is slow to respond, this delay is known
to occur on vacant SATA ports
Jul 17 13:32:37 piros kernel: ata4: port failed to respond (30 secs)
Jul 17 13:32:37 piros kernel: ata4: COMRESET failed (device not ready)
Jul 17 13:32:37 piros kernel: ata4: hardreset failed, retrying in 5 secs
Jul 17 13:32:42 piros kernel: ata4: hard resetting port
Jul 17 13:32:42 piros kernel: ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Jul 17 13:32:42 piros kernel: ata4.00: configured for UDMA/133
Jul 17 13:32:42 piros kernel: ata4: EH complete
Jul 17 13:32:42 piros kernel: SCSI device sdd: 488397168 512-byte hdwr sectors
(250059 MB)
Jul 17 13:32:42 piros kernel: sdd: Write Protect is off
Jul 17 13:32:42 piros kernel: SCSI device sdd: drive cache: write back
-------------------------------------------------


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Levente Farkas 2008-06-18 14:21:59 EDT
please close this bug since it's been already solved
Comment 2 David Milburn 2010-05-07 12:22:07 EDT
Closing as requested.

Note You need to log in before you can comment on or make changes to this bug.