Bug 24874 - aic7xxx SMP oops
Summary: aic7xxx SMP oops
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brock Organ
URL:
Whiteboard: Florence RC-1
Keywords:
: 24893 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-24 18:53 UTC by Brock Organ
Modified: 2007-04-18 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 10:52:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brock Organ 2001-01-24 18:53:28 UTC
testing qa0124.0 test tree on a dell poweredge 6300 using aic7xxx, the
kernel panics on SMP kernel boot (default lilo "linux" label), but NOT on
linux-up boot or linux default boot if run over the serial console
...                                                                                 
EIP:    0010:[<c010807d>]                                                  
EFLAGS: 00000087                                                           
eax: c0282b24   ebx: f8800000   ecx: 00000010   edx: f7f92800              
esi: f7a1dcc0   edi: 00002000   ebp: 00000010   esp: f7a25ce8              
ds: 0018   es: 0018   ss: 0018                                             
Process insmod (pid: 13, stackpage=f7a25000)                               
Stack: 
c02231bc f7a25cb0 f7797c00 00001000 fb002000 00000000 c0115c65 00001000
00000001 fb0020ff f7797c00 02900117 00000000 00000000 f88268a5 fb002000     
00000100 00000010 fb002000 00000000 02900117 00ffffff 0000ffff 00000100     
Call Trace: 

[<c02231bc>] [<fb002000>] [<c0115c65>] [<fb0020ff>] [<f88268a5>]
[<fb002000>] [<fb002000>] 

[<f883f954>] [<f8835094>] [<c02200f9>] [<f883c820>] [<f8824241>]
[<f882e44e>] [<f883dfc0>] [<f883f954>]

[<f8826803>] [<f883f954>] [<c0139b68>] [<c015cc0f>] [<c015cced>]
[<fffc9f8b>] [<c0130ee5>] [<c012935d>]

[<f883dfc0>] [<f8823702>] [<f883dfc0>] [<c0126f42>] [<c0126fd9>]
[<c0127143>] [<f883dfc0>] [<f8807cd8>]

[<f883dfc0>] [<f8823000>] [<f88266c7>] [<f883dfc0>] [<f883dfc0>]
[<c0119d45>] [<f8840408>] [<f881f000>]

[<f8823060>] [<c01091c7>]

Code: 75 f8 f0 81 28 00 00 00 01 0f 85 e4 ff ff ff c3 8d 76 00 f0          
console shuts up...                                                        
ERROR: insmod exited abnormally!

Comment 1 Arjan van de Ven 2001-01-24 19:53:41 UTC
Is this the old or the new aic7xxx driver?

Comment 2 Glen Foster 2001-01-25 00:40:52 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 3 Gene Czarcinski 2001-02-06 19:20:11 UTC
I am also getting the oops .. with 2.4.0-0.99.23 from rawhide BUT i do not get
the problem when I run the beta3 (fisher) kernel 2.4.0-0.99.11.

Also, this only occurs with the smp kernel.  The up kernel boots fine.

Comment 4 Doug Ledford 2001-02-09 10:50:06 UTC
This is a bug in the general mid layer SCSI code in dealing with driver init
sequences that take longer than one second.  This should be fixed in the latest
2.4.1-0.1 and later kernel builds by using the aic7xxx 5.2.3 driver instead of
the 6.1.0 driver which bypasses the new_eh_code which is the cause of the oops.

Comment 5 Doug Ledford 2001-02-09 10:52:02 UTC
*** Bug 24893 has been marked as a duplicate of this bug. ***

Comment 6 Brock Organ 2001-02-15 15:18:31 UTC
verified fix with qa0214.0 ...


Note You need to log in before you can comment on or make changes to this bug.