Bug 248740 - Printers with a DeviceURI of hp:/usb/XXX no longer work
Summary: Printers with a DeviceURI of hp:/usb/XXX no longer work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 248916 249014 249025
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2007-07-18 14:33 UTC by Hans de Goede
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-22 09:53:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2007-07-18 14:33:49 UTC
After updating to the latest rawhide yesterday my printer stopped working.

Downgrading to hplip + hpijs + libsane-hpaio from F-7 updates, fixes this.

I've also tried to change the DeviceURI from:
hp:/usb/psc_1300_series?serial=MY38O1F0XF9F
to:
hal:///org/freedesktop/Hal/devices/usb_device_3f0_3b11_MY38O1F0XF9F_if1_printer_MY38O1F0XF9F

As a new "dynamic" printer was added to my cups config using this as DeviceURI,
but that didn't help either.

My printer is a HP PSC 1350 connected through USB, with the rawhide hplip+hpijs,
hp-toolbox still saw the printer fine if run as root, but printing didn't work,
ps aux revealed hanging (sleeping) hpijs and ghostscript processes.

I will happily do more testing, I like the idea of getting rid if the hplip
daemons, but sofar that doesn't seem to work for me.

Comment 1 Tim Waugh 2007-07-19 16:19:08 UTC
This is caused by udev not making /dev/bus/usb nodes as far as I can tell.

Comment 2 Hans de Goede 2007-07-22 09:53:09 UTC
I can confirm that hplip-2.7.6-9.fc8 fixes this, closing.



Note You need to log in before you can comment on or make changes to this bug.