Bug 248754 - Wifi signal strength not available for rt2500
Summary: Wifi signal strength not available for rt2500
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-18 15:10 UTC by Igor Jagec
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version: 2.6.22.1-45.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 17:40:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Igor Jagec 2007-07-18 15:10:14 UTC
Description of problem:

The GNOME network applet doesn't show the signal strength on my Wlan0 device, 
and network works just fine. I have rt2500 based wireless card. The applet 
works just fine on my F7 with legacy rt2500 drivers, but it does not with 
Fedora's supplied (buggy) drivers.

Version-Release number of selected component (if applicable):

2.18.0-7.fc7 and above.

How reproducible:

Every time.

Actual results:

The applet does not show signal strength.

Expected results:

To show signal strength.

Comment 1 Ignacio Vazquez-Abrams 2007-07-18 15:19:05 UTC
Modified since it's an issue with the kernel module instead.

Comment 2 Ivo van Doorn 2007-07-24 11:44:58 UTC
At this moment rt2x00 only reports the RSSI of received frames,
"Noise" and "Signal" reporting are both disabled.

Main reason for the disabling of those statistics is that I am not sure what 
values should actually be passed on. rt2x00 cannot measure "Noise", so all it 
could report is the currently configured AGC VGC value.
As for the "Signal", there isn't a real value which can be reported. The 
legacy driver that did report the "Signal". But that caused dozens of bug 
reports by users because the "Signal" value didn't make a lot of sense. This 
was because the reported "Signal" was actually the "RSSI - AGC VGC", which 
isn't the most sensible value.

I am considering reporting the AGC VGC value as "Noise" again, but I have no 
ideas on a possible value "Signal" value yet.

Comment 3 Ivo van Doorn 2007-07-25 21:03:54 UTC
I have rechecked the RX descriptors, documentation and the legacy drivers.

With the legacy drivers the Signal value was sometimes filled in with the 
Bitrate at which the frame was received. This is hardly a usable value.

But other then that I can't find anything usefull that can be used for the 
signal value...

I could possibly use the AGC VGC value, but I am a bit reluctant about that 
since I more see it as the noise value (Although off course this value is not 
measured).

So if the Signal field should really be filled, I can either copy the rssi 
value or use the AGC VGC value... Neither sounds too appearling. :S

John,

Do you have any suggestions about this?

Comment 4 Ivo van Doorn 2007-07-31 18:34:52 UTC
rt2x00 2.0.5 has just been released containing signal reporting.

Comment 5 John W. Linville 2007-08-03 16:54:16 UTC
Please try the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=12706

Do these resolve the issue?

Comment 6 Igor Jagec 2007-08-04 15:58:27 UTC
It seems it does. I installed 2.6.22.1-45.fc7 on my Rawhide system and Gnome 
applet shows the signal strength. Cheers!


Note You need to log in before you can comment on or make changes to this bug.