Bug 248774 - Package dependency is ignored
Package dependency is ignored
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 13:58 EDT by Lubomir Kundrak
Modified: 2014-01-21 17:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 10:00:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full yum -d6 update output (56.64 KB, text/plain)
2007-07-26 05:05 EDT, Lubomir Kundrak
no flags Details

  None (edit)
Description Lubomir Kundrak 2007-07-18 13:58:17 EDT
Description of problem:

I am unable to update some of my packages from jpackage that depend on
xml-commons-api due to a very strange reason. Here's what happens:

[root@breaker devel]# rpm -q xml-commons{,-apis} 
xml-commons-1.3.02-0.b2.7jpp.10
xml-commons-apis-1.3.02-0.b2.7jpp.10
[root@breaker devel]# yum update
...
--> Processing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 for package:
xml-commons-apis
...
Error: Missing Dependency: xml-commons = 1.3.02-0.b2.7jpp.10 is needed by
package xml-commons-apis

As you can see, when attempting to update, yum says that it can't find a
dependency that actually exists and is installed.

When I try to install the dependent package itself, it yields no problems:

[root@breaker devel]# rpm -e --nodeps xml-commons-apis
[root@breaker devel]# yum -y install xml-commons-apis-1.3.02-0.b2.7jpp.10.i386.rpm
...
Installed: xml-commons-apis.i386 0:1.3.02-0.b2.7jpp.10
Complete!
[root@breaker devel]# 

Additional info:

I am not sure whether this is a rpm problem or a yum problem. Please
reassign when appropriate.

This morning my roommate had a quite similar problem while trying to install
his homebrewed mencoder subpackage that didn't see an installed mplayer
subpackage coming from the very same package. What it had in common with
this was a horribly long version string. But this might be a wrong guess.

Also, I am not the only one with this problem. See this URL:
http://forums.fedoraforum.org/showthread.php?t=161024
Comment 1 Jeremy Katz 2007-07-24 16:29:22 EDT
Can you see if this is fixed with yum 3.2.2 in updates-testing?
Comment 2 Lubomir Kundrak 2007-07-25 10:10:38 EDT
Jeremy: No, it's not fixed.
Comment 3 Jeremy Katz 2007-07-25 10:17:08 EDT
Can you attach teh full output of 'yum -d6 update'?
Comment 4 Lubomir Kundrak 2007-07-26 05:05:19 EDT
Created attachment 159997 [details]
Full yum -d6 update output

[root@breaker lkundrak]# yum -d6 update 2>&1 |tee yum-248774.log
Comment 5 Lubomir Kundrak 2007-07-26 06:40:43 EDT
Posts in the forum starting from comment 10 [1] imply that this is not a bug
of yum, but simply of the packages.

[1] http://forums.fedoraforum.org/showpost.php?p=835623&postcount=10

Jeremy: Do you agree? And if it is, wouldn't there be a way to let non-technical
user know what went wrong with the update? (the error message obviously doesn't
explain it enough).
Comment 6 Jeremy Katz 2007-07-26 10:00:49 EDT
Yes, definitely a package bug.  I'll try to spend some time on making the errors
a little bit more clear on how the problem is coming in.

Note You need to log in before you can comment on or make changes to this bug.