Bug 248786 - UnicodeDecodeError in authconfig
UnicodeDecodeError in authconfig
Status: CLOSED DUPLICATE of bug 237956
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
7
All Linux
high Severity high
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 15:28 EDT by Jochen Schmitt
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 20:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2007-07-18 15:28:17 EDT
Description of problem:

when I try to call authconfig without any parameter, I will get the following
messages:

Traceback (most recent call last):
  File "/usr/share/authconfig/authconfig.py", line 780, in <module>
    module.run()
  File "/usr/share/authconfig/authconfig.py", line 358, in run
    self.parseOptions()
  File "/usr/share/authconfig/authconfig.py", line 237, in parseOptions
    parser.parse_args(["-h"])
  File "/usr/lib64/python2.5/optparse.py", line 1378, in parse_args
    stop = self._process_args(largs, rargs, values)
  File "/usr/lib64/python2.5/optparse.py", line 1422, in _process_args
    self._process_short_opts(rargs, values)
  File "/usr/lib64/python2.5/optparse.py", line 1529, in _process_short_opts
    option.process(opt, value, values, self)
  File "/usr/lib64/python2.5/optparse.py", line 782, in process
    self.action, self.dest, opt, value, values, parser)
  File "/usr/lib64/python2.5/optparse.py", line 804, in take_action
    parser.print_help()
  File "/usr/lib64/python2.5/optparse.py", line 1648, in print_help
    file.write(self.format_help().encode(encoding, "replace"))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 208:
ordinal not in range(128)

Version-Release number of selected component (if applicable):
authconfig-5.3.13-4.fc7

How reproducible:
Call the application without any parameters from the command line

Steps to Reproduce:
1. # authconfig

  
Actual results:
See above.
Comment 1 Tomas Mraz 2007-07-18 16:03:50 EDT
What is your LANG environmental variable set to?

Could you also please try authconfig-5.3.15-1.fc7 as soon as it hits
updates-testing repository?
Comment 2 Jochen Schmitt 2007-07-19 14:09:40 EDT
LANG is set to 'de_DE.utf8
'

Sorry, but the most recent cvs release produced the same bug as reported.
Comment 3 Tomas Mraz 2007-07-19 17:52:49 EDT
It seems like a problem in recent python. The help should be decoded as UTF-8
and not ascii.
Comment 4 Jeremy Katz 2007-07-19 20:37:52 EDT

*** This bug has been marked as a duplicate of 237956 ***

Note You need to log in before you can comment on or make changes to this bug.