Bug 24879 - X Does not work
X Does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 15:22 EST by Aaron Brown
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-16 00:44:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Brown 2001-01-24 15:22:49 EST
After an NFS, TUI, Everything, Automatic Graphical mode install,
the system kept trying to start X on bootup, but was never able to (screen
kept flashing off and on).  When I bring it up in init mode 3, I am able to
use text mode fine, but when I issue "startx", the system hangs.
Comment 1 Aaron Brown 2001-01-24 15:32:06 EST
I just found out that if boot the system in mode 3, and run Xconfigurator,
startx works fine.  So, should this be filed under something besides XFree86?
Comment 2 Aaron Brown 2001-01-24 15:55:24 EST
Once the system has been rebooted, things get screwy again.  Screen redraws
don't happen, and if I try to switch back from another VC, the system hangs.
Comment 3 Mike A. Harris 2001-01-28 10:51:53 EST
Try out beta 3 and see if it still occurs.
I don't have an ia64 kicking around, so I can't test this at all.  ;o)
I've Cc'd Bill as I believe he is the ia64 guru unless I'm horribly
mistaken.  ;o)

However, if anyone wants to send me an 8 way 1Ghz ia64 box strictly
for debugging purposes, I wouldn't mind.  ;o)
Comment 4 Mike A. Harris 2001-01-28 13:31:56 EST
ALso, you should indicate what video card you are using and as many other
details as might help track the problem down including making a file
attachment to the bug report with your X server logs, and configuration
files.

Comment 5 Aaron Brown 2001-01-28 15:17:14 EST
This problem is 95% fixed in beta-3.  I'm only seeing problems on about 1 out 
of 4 Big Surs, and I'm pretty sure that's because of "questionable" hardware.  
Also, I'm aware of bug reporting protocol.  There were *no* differences between 
the logs of a working IA-64 GUI config, and a non-working one.  All of the IA-
64s we have have the same exact video card in them (ATI Rage 128), so I made 
(the possibly) incorrect assumption that I didn't have to include information 
about what video card I was using.  If you believe you should not be assigned 
IA-64 bugs, please let Preston know on Monday, so we can make sure they get 
assigned to the right folks.  Thanks.
Comment 6 Matt Domsch 2001-02-15 12:02:33 EST
Date: Tue, 13 Feb 2001 15:27:31 -0500
From: Bill Nottingham <notting@redhat.com>
To: testers-list@redhat.com
Subject: Re: Anyone testing IA64 bits??

Short answer is that the int10 stuff is somewhat fubar on
ia64. On server machines it can't read the video BIOS, on
workstation machines it has a nasty habit of locking the
machine if it's using a PCI card. There are some fixes
in trunk that are supposed to fix it from Marc Aurele La France
(who I'm pretty sure I just butchered the name of), they
didn't fix the workstation issue when I tried, and I
haven't built a package to try them on the server machines
yet.

Bill
Comment 7 Mike A. Harris 2001-02-16 00:44:03 EST
abrown - you're right, bad assumption about me knowing what hardware is in ia64
machines.  Doing bugzilla queries based on video card type, etc.. also doesn't
work if that information isn't in them.

When a bug report doesn't contain enough info for me to do anything about it,
I have to request more info.  Doesn't matter where the report came in from.
I wasn't trying to challenge you on protocol.  Sorry if you took it that
way.  It's better for me to ask than to just hit PRIORITY=LOW, or
somesuch..  ;o)

I also don't always look to see who reported the bug and wether it was
internal or not.

I will talk to Preston about having ia64 bugs assigned to someone else.
Thanks for the idea.
Comment 8 Bill Nottingham 2001-02-27 19:34:41 EST
Should be fixed with the 4.0.2-10 X packages.
Comment 9 Matt Domsch 2001-03-01 11:46:44 EST
Confirmed fixed in XFree86-4.0.2-11.

Note You need to log in before you can comment on or make changes to this bug.